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Copyright

This document may not, in whole or part, be copied, photocopied, reproduced, 
translated, or reduced to any electronic medium or machine-readable form without 
prior written consent from Lattice Semiconductor Corporation.

The software described in this manual is copyrighted and all rights are reserved by 
Lattice Semiconductor Corporation. Information in this document is subject to 
change without notice.

The distribution and sale of this product is intended for the use of the original 
purchaser only and for use only on the computer system specified. Lawful users of 
this product are hereby licensed only to read the programs on the disks, cassettes, or 
tapes from their medium into the memory of a computer solely for the purpose of 
executing them. Unauthorized copying, duplicating, selling, or otherwise distributing 
this product is a violation of the law.

Trademarks

Lattice Semiconductor Corporation, L Lattice Semiconductor Corporation (logo), L 
(stylized), L (design), Lattice (design), LSC, Beyond Performance, E2CMOS, 
FIRST-TIME-FIT, GAL, Generic Array Logic, In-System Programmable, In-System 
Programmability, ISP, ispATE, ispDesignEXPERT, ispDOWNLOAD, ispGAL, 
ispGDS, ispGDX, ispGDXVA, ispJTAG, ispLEVER, ispLSI, ispMACH, ispPAC, 
ispSOC, ispSVF, ispTURBO, ispVIRTUAL MACHINE, ispVM, LINE2AR, MACH, 
MMI (logo), PAC, PAC-Designer, PAL, PALCE, Performance Analyst, Silicon 
Forest, Speedlocked, Speed Locking, SuperBIG, SuperCOOL, SuperFAST, 
SuperWIDE, UltraMOS, V Vantis (design), Vantis, Vantis (design), Variable-Grain-
Block, and Variable-Length-Interconnect are either registered trademarks or 
trademarks of Lattice Semiconductor Corporation or its subsidiaries in the United 
States and/or other countries. ISP is a service mark of Lattice Semiconductor 
Corporation. 

GENERAL NOTICE:  Other product names used in this publication are for 
identification purposes only and may be trademarks of their respective companies.

Lattice Semiconductor Corporation
5555 NE Moore Court
Hillsboro, OR 97124

(503) 268-8000

February 2002
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Limited Warranty

Lattice Semiconductor Corporation warrants the original purchaser that the Lattice 
Semiconductor software shall be free from defects in material and workmanship for a 
period of ninety days from the date of purchase. If a defect covered by this limited 
warranty occurs during this 90-day warranty period, Lattice Semiconductor will 
repair or replace the component part at its option free of charge.

This limited warranty does not apply if the defects have been caused by negligence, 
accident, unreasonable or unintended use, modification, or any causes not related to 
defective materials or workmanship.

To receive service during the 90-day warranty period, contact Lattice Semiconductor 
Corporation at:

Phone: 1-800-LATTICE or (408) 826-6002
E-mail: techsupport@latticesemi.com

If the Lattice Semiconductor support personnel are unable to solve your problem over 
the phone, we will provide you with instructions on returning your defective software 
to us. The cost of returning the software to the Lattice Semiconductor Service Center 
shall be paid by the purchaser.

Limitations on Warranty

Any applicable implied warranties, including warranties of merchantability and 
fitness for a particular purpose, are hereby limited to ninety days from the date of 
purchase and are subject to the conditions set forth herein. In no event shall Lattice 
Semiconductor Corporation be liable for consequential or incidental damages 
resulting from the breach of any expressed or implied warranties.

Purchaser’s sole remedy for any cause whatsoever, regardless of the form of action, 
shall be limited to the price paid to Lattice Semiconductor for the Lattice 
Semiconductor software. 

The provisions of this limited warranty are valid in the United States only. Some 
states do not allow limitations on how long an implied warranty lasts, or exclusion of 
consequential or incidental damages, so the above limitation or exclusion may not 
apply to you.

This warranty provides you with specific legal rights. You may have other rights 
which vary from state to state.
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ispLEVER 1.0

The ispLEVER™ 1.0 software supports ispLSI®(1000, 2000, 5000VE, and 8000), ispMACH® 
(4000B/C, 4A3, 4A5, 5000VG), MACH 4, MACH 4 Low Voltage, MACH 5, MACH 5/1, MACH 5 
Low Voltage, GAL®, ispGAL®, and ispGDX® device families.

The following topics are discussed in this section:

� Licensing

� Product Information

� New Features and Enhancements

� Known Issues and Solutions
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Licensing

Supported Platforms

The ispLEVER 1.0 software supports Windows®XP, Windows 2000 (Workstation mode only). 
Windows NT, and Windows 98.

License Features

� LSC_BASE license feature supports all ispLSI, ispMACH, MACH, GAL, ispGAL, and 
ispGDX devices up to 768 macrocells.

� LSC_ADVANCED license feature supports all Lattice high-density CPLDs. 
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Product Information

This ispLEVER 1.0 software provides Project Navigator, ABEL® Compiler, ABEL-HDL and 
schematic entry, gate-level timing and functional and timing simulation, timing analysis, debug tools, 
and our ispVM™ System programming suite.

The ispLEVER 1.0 software comprises four products. 

HDL Base

The ispLEVER HDL Base software includes ispLEVER, ispVM System; Mentor Graphics® 

ModelSim® and LeonardoSpectrum™; and Synplicity® Synplify® (Base) tools.

HDL Advanced

The ispLEVER HDL Advanced software includes ispLEVER, ispVM System; Mentor Graphics 
ModelSim and Leonardo Spectrum; and Synplicity Synplify (Advanced) tools.

Exemplar Advanced

The ispLEVER Exemplar Advanced software includes ispLEVER, ispVM System, and Mentor 
Graphics (Advanced) tools.

Advanced System

The ispLEVER Advanced System software includes ispLEVER and ispVM System.
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New Features and Enhancements

The following new features and enhancements are available in all the ispLEVER 1.0 software products:

� New Device Families Support

� Unified Design Flow for New and Legacy Devices

� New Style Project Navigator

� HTML Fitter Report Format

� Unified Constraint Editor

� ispEXPLORER™

� ispUPDATE™

� New Version CAE Tools

� SVF File Generation

� Checksum as USERCODE Default

� Updates to ispVM Programming Software

New Device Families Support

This release supports the following new device families:

� SuperFast ispMACH 4000B/C 

� SuperBig ispMACH 5000VG

� SuperWide ispLSI 5000VE

Unified Design Flow for New and Legacy Devices

The new ispLEVER software provides unified constraint flow and design environment for all Lattice 
devices, including new and legacy devices. The unified design flow provides fast, efficient runtime and 
competitive device performance and utilization. 
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Supported Legacy Devices

The following legacy devices are supported:

� GAL and ispGAL

� ispLSI 1000, 2000, and 8000 families

� MACH 4 and MACH 5, ispMACH 4A 3/5 families

� ispGDX

New Style Project Navigator

The standard Windows style is applied to the Project Navigator.

Collapse/Expand Tree View in Sources/Processes Window

The tree view control is used in both Sources and Processes windows of the Project Navigator 
(Figure 1). This allows you to collapse and expand the submodules in the design hierarchy tree or the 
subprocesses in the Processes window. You can select the vertical bar at the center of the window to 
adjust the sizes of the windows, and the setting will be saved after you exit the Project Navigator.

Figure 1.  Tree View in Sources/Processes Window

New Output Panel with Report Viewer Embedded

The Output Panel is by default a docked window at the bottom of the Project Navigator. It displays the 
Automake log file, indicating errors and warnings. With the Report Viewer embedded in it, the Output 
Panel can display various report files on different tabs. You can choose to view report files in either the 
Output Panel or the Report Viewer.

To view report files in the Output Panel:

1. Choose Options > Environment to open the Environment Options dialog box.

2. On the Log tab, clear Using Report Viewer.
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The Output Panel can be undocked or moved to a new position. Right-click in the Output Panel to display
pop-up menus, which allow you to perform Copy, Clear, Print, and other common operations. 

Context-Sensitive Pop-Up Menu

The Project Navigator provides a “context-sensitive” pop-up menu when you right-click on certain 
items in the Sources window, Processes window, or the Output Panel. The menus vary depending on 
where and when you click. Command definitions are available by pressing F1.

Single-Click to Start Processes

By default, processes are started by double-clicking the process in the Processes window. You can 
change this to a single click. 

To start a process via a single click:

1. Choose Options > Environment to open the Environment Options dialog box.

2. On the General tab, select Single Click to Invoke Process.

Docked Toolbars

All the toolbars are by default attached to one edge of the Project Navigator window. You can dock a 
toolbar below the Project Navigator menu bar, or to the left, right, or bottom edge of the Project 
Navigator window. 

To move a toolbar:

1. Click the move handle  on a docked toolbar or click the title bar on a floating toolbar.

2. Drag the toolbar to a new location. If you drag the toolbar to the edge of the Project 
Navigator window, it becomes a docked toolbar.
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New Tools Toolbar

The Tools toolbar (Figure 2) provides you with quick access to frequently used tools. You can toggle the 
display of this toolbar using the View > Tools Toolbar command.

Figure 2.  Tools Toolbar

Tool Tip Function

LeonardoSpectrum Equivalent to Tools > LeonardoSpectrum 
Synthesis; starts LeonardoSpectrum synthesis tool 
directly.

Synplify Equivalent to Tools > Synplify Synthesis; starts the 
Synplicity Synplify synthesis tool directly.

ModelSim Equivalent to Tools > ModelSim Simulator; starts 
the ModelSim Simulator directly.

ispEXPLORER Equivalent to Tools > ispEXPLORER; starts 
ispEXPLORER.
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Enhanced Tools Menu

Some items on the Tools menu (Figure 3) have been enhanced with a graphic icon. 

Figure 3.  Enhanced Tools Menu

Select RTL Synthesis Dialog Box

The RTL Synthesis dialog box (Figure 4) allows you to select the synthesis tool for each project. You 
open this dialog box by choosing Options > Select RTL Synthesis. The synthesis tool you select is 
project-specific. For example, if you select the “LeonardoSpectrum” or “Synplicity” option for a 
project, this option will remain for this specific project.

The Select RTL Synthesis dialog box has been enhanced to include the As Default option. With this
option checked, the tool you select in this dialog box will become the default synthesis tool for all your
projects. 

Figure 4.  Select RTL Synthesis Dialog Box
8 ispLEVER 1.0 Release Notes



HTML Fitter Report Format

A new HTML-based fitter report (Figure 5) makes report viewing fast and efficient through a standard 
Internet browser. Hyperlinks in the report allow you to quickly navigate signal paths for easy design 
debugging. When you run the HTML Fitter Report process, the report opens in your default Internet 
browser. 

Figure 5.  HTML Fitter Report
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Unified Constraint Editor

The Constraint Editor (Figure 6) has a look similar to a Microsoft® Excel spreadsheet format. Flow 
sheets are incorporated at the bottom to facilitate an Engineering Design Flow Methodology. 

Figure 6.  Constraint Editor Screen

The Constraint Editor reads the constraint file and displays the constraint settings. It lets you specify and
modify pin and node location assignments, group assignments, I/O type settings, power level settings,
resource reservations, PLL attributes, as well as output slew-rates and JEDEC file options. Modifications
to the constraints can be made either through function dialog boxes or on the flow sheets. 

Direct Constraints Editing

This new feature allows you to edit most constraints directly on the flow sheets without opening any 
dialog boxes. Editing constraints can be as simple as double-clicking a table cell and typing or selecting 
a desired constraint value. The constraint options on the pop-up menus also facilitate direct constraints 
editing. 

When you edit directly, the Constraint Editor performs a simple check to ensure that your entry is
applicable. For example, if you enter a pin number, the Constraint Editor checks to make sure the entry
is applicable.
10 ispLEVER 1.0 Release Notes



Auto-Increment and Auto-Decrement

You can auto-increment or auto-decrement pin, macrocell, GLB, and segment numbers in the Pin 
Attribute spreadsheet. Select a group of cells in the pin column, and right-click. In the popup menu, 
choose Pin Number to open the Enter a Pin Number dialog box (Figure 7). In the Enter a Pin Number 
dialog box, enter a pin number, and click OK to increment. Select the Decrement Assignment box to 
decrement, then click OK.

Figure 7.  Enter a Pin Number Dialog Box

Pop-Up Menus

Various pop-up menus are available when you right-click in any sheet of the Constraint Editor. The 
menus enable you to edit constraint values, open dialog boxes, clear constraints, etc. 

100 Step Undo/Redo

The Undo and Redo commands on the Edit menu allow you to reverse the edit process. Undo backs up 
one step each time you click the Undo command. You can reverse up to 100 steps from the time the 
constraint file was opened. Redo repeats the undone steps up to the point of the first Undo.
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Enhanced Location Assignment Dialog Box

If you want to assign multiple signals to successive pins/macrocells at once, you can use the Decrement 
Assignment option to control the assignment order. This option is not visible until you have selected 
more than one signal in the Signals List. 

Figure 8.  Enhanced Location Assignment Dialog Box 

As shown in Figure 8, if Decrement Assignment is cleared, the Constraint Editor assigns the first
selected signal (display_0_) to the highlighted pin/macrocell ( A5) and then successively assigns the
other selected signals to the pins/macrocells following the highlighted pin/macrocell (display_1_ to
A6; display_2_ to A7; display_3_ to A8). Checking Decrement Assignment also assigns the first
selected signal (display_0_) to the highlighted pin/macrocell ( A5), but the other selected signals are
successively assigned to the pins/macrocells listed prior to the highlighted pin/macrocell (display_1_
to A4; display_2_ to A3; display_3_ to A2).
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Enhanced Group Assignment Dialog Box

The Group Assignment Dialog Box (Figure 9) has been enhanced to include the Keep Order option as 
well as the  (Move Up) and  (Move Down) buttons. Use the two buttons to control signal order 
in a group. You can then check Keep Order to make the specified signal order take effect during the 
fitting process. 

The new Filter button works with the four check boxes to improve the filter function. You can type text
or wildcards in the text box and then click Filter to further filter the signals displayed in the Available
Signals list. 

Figure 9.  Enhanced Group Assignment Dialog Box
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Enhanced Default Setting Dialog Box

The Default Setting dialog box (Figure 10) has been improved to display two columns. The left column 
displays constraint names. When you click a constraint name, its available values are shown in the right 
column. The constraint names and values listed in the two columns are device-dependent. 

Figure 10.  Default Setting Dialog Box

NOTE For ispMACH 4A3, MACH 4A5, MACH 4, MACH 4LV, MACH 5, 
MACH 5/1, and MACH 5 LV devices, the parametric Pullup settings are 
also set in the dialog box. By definition, the Default Setting parameters 
apply for the whole device. Signal specific settings are applied via the Pin 
Attribute spreadsheet.
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Assign Power Level for All Signals in a GLB

For ispMACH4A3/4A5 and MACH4/MACH5 device families, you can use the Assign Power Level 
dialog box (Figure 11) to apply a power level to a certain GLB. All signals in that GLB will then be set 
to that power level. 

Figure 11.  Assign Power Level Dialog Box
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Customize Colors

In the Set Colors dialog box (Figure 12), you can select colors to be displayed in the Constraint Editor 
sheets and the Package View main window. 

Figure 12.  Set Colors Dialog Box

Package View

The Constraint Editor Package View window (Figure 13) shows the actual pin assignments in the 
selected package. By default, the system (non-user) pins are highlighted in gray; reserved pins are in 
lime; assigned input pins are in blue; output pins in yellow and bi-directional pins in magenta. Unused 
pins are blank. You can also change these system default colors by choosing Edit > Set Colors. You can 
view this window by choosing Device > Package View from the Constraint Editor.

Figure 13.  Constraint Editor Package View
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Drag and Drop Pin Assignments

The Package View provides a drag and drop feature for making pin assignments. You can drag signals 
from the signal tree of the Constraint Editor to the Package View window. You can also drag and drop 
signals inside the Package View window, as shown in Figure 14. 

Figure 14.  Drag and Drop Pin Assignments in Package View

You can drag and drop the input, output, or bidir signals from the signal list tree on the left side of the
Pin Attribute sheet into the Package View package pins. When you select an assigned package pin, the
associated signal in the Pin Attribute sheet will be highlighted.

Edit Pins

You can edit pins in the Package View, as shown in Figure 15, by right-clicking on the pin and selecting
the Unlock, Reserve, Un-reserve, Disable, or Locate command in the pop-up menu. You can unlock
assigned pins in the Package View.

Figure 15.  Edit Pin in Package View
ispLEVER 1.0 Release Notes 17



Translating Mappable ispLSI and MACH Legacy Constraints

The new ispLEVER software gives you an improved and more unified constraint flow. You must 
convert legacy ispDesignEXPERT 8.2, 8.3, or 8.4 constraint files to ispLEVER constraint files before 
running your design in ispLEVER. To convert the constraint files, you can use the Legacy Constraints 
Translator by double-clicking on the Legacy Constraints Translator icon  in the Lattice 
Semiconductor program menu, or you can use the legacy2lci command line utility provided with the 
ispLEVER software, located in <install_path>\ispcpld\bin. 

MACH Devices

For MACH4 and MACH5 designs created with ispDesignEXPERT 8.2, 8.3, or 8.4 use a .vci 
constraint file, which must be converted to an .lci constraint file for ispLEVER.

ispLSI Devices

For ispLSI 1000, 2000, and 8000 family devices, designs created with ispDesignEXPERT 8.2, 8.3, or 
8.4 use a Parameter File (.par), a Property File (.prp), a Pin File (.ppn), a User Code File (.ues), a 
Pin Reservation File (.rsp), or a Fitting Options Setting File (.xct), all of which can be converted to a 
single LCI file for ispLEVER. For details on constraint mapping, see “ispLSI Legacy Constraints 
Support” on page 22.

NOTE Designs created in Lattice software older than ispDesignEXPERT 8.x 
must first be opened in ispDesignEXPERT 8.x, and then saved as an 
ispDesignEXPERT 8.x project.

NOTES • Because the design flow is changed from ispDesignEXPERT 8.x to 
ispLEVER 1.0 for ABEL designs, some of the internal signal labels 
may not match. Node constraints such as Regtype, Preserve, Protect 
and ECP might not convert properly to ispLEVER 1.0. 

• Before beginning the conversion process, be sure to save an archive 
copy of your entire project directory.
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Converting Files Using the Legacy Constraints Translator

The Legacy Constraints Translator (Figure 16) is a graphical user interface application that reads the 
<projectName>.syn file, and other files according to the optional parameters.

Figure 16.  Legacy Constraints Translator

To convert files using the Legacy Constraints Translator:

1. Archive your project directory so that you will have a backup.

2. From the Lattice program menu, select Legacy Constraints Translator to open the 
program.

3. In the dialog, do the following:

a. In Project Name, select the ispDesignEXPERT 8.x project that you want to convert.

b. Under Select Device, the default is the current target device. If the target device is not 
supported, all options are disabled. To select a different device, you must change the 
project name in the Project Name field. 

c. Under Options, select the files that you want to convert.
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.

4. Click OK. The selected legacy files are converted to ispLEVER files in the specified 
project directory, and the application exits. If you click Apply before clicking OK, you 
can re-select various options to convert, and stay in the application until you click OK to 
execute and exit.

Converting Files Using the legacy2lci Command Line Application

The utility “legacy2lci” reads all the ispDesignEXPERT 8.x project and constraint files (.syn, .vci, 
.prp, .par, .ppn, and .rsp) to create the ispLEVER 1.0 constraint file (.lci). Once the LCI 
constraint file is successfully created, you can load the Project File (.syn) from the ispLEVER Project 
Navigator. Note that if you did not run the legacy2lci utility to create the LCI file prior to opening the 
SYN file, the ispLEVER Project Navigator will automatically generate a “blank” LCI file with the 
defaulted device. 

To translate design constraint files from 8.x into ispLEVER:

1. Archive your project directory so that you will have a backup.

2. For MACH4 or MACH5 devices, using the Windows Command Prompt, change directory 
(cd) to your project directory, and type (on one line): 

<install_path>\ispcpld\bin\legacy2lci <project_name>

3. For ispLSI 1000 and 2000 devices, using the Windows Command Prompt, change 
directory (cd) to your project directory, and type (on one line):

<install_path>\ispcpld\bin\legacy2lci <project_name>

[-prp <filename_ext>] 

[-p [-par <filename_ext>]] 

[-n [-ppn <filename_ext>]] 

[-u [-ues <filename_ext>]] 

[-r [-rsp <filename_ext>]] 

[-x [-xct <filename_ext>]]

[-ppnOnly <filename_ext>] 

where [] denotes optional parameters for 1000 and 2000 devices:

-prp converts a user property file name that differs from the project name, 
<project_name>.prp. It is recommended that you not use the 8.4 system 
created _edif.prp. However, you can use the _edif.prp file in those cases 
where the <project_name>.prp file is 0 bytes or empty.

NOTE For ispLSI devices, all options are available for file extension selection. 
For MACH devices, not all options are available for selection.
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-p converts the PAR file. By default, the PAR file is <project_name>.par. 
When you use the –p option, the Part Name, PRP, and PPN defined in the PAR 
file are ignored.

-par is used to specify a PAR file name that differs from the project name, 
<project_name>.par. 

-n converts the PPN file. By default the PPN file is <project_name>.ppn. 
When you use the –n option, the pin assignments in the PPN file are used, and 
those defined in the PRP file are ignored.

-ppn is used to specify a PPN file name that differs from the project name, 
<project_name>.ppn. 

-u converts a UES file.

-ues is used to specify a UES file name that differs from the project name, 
<project_name>.ues.

-r converts an RSP file.

-rsp is used to specify an RSP file name that differs from the project name, 
<project_name>.rsp.

-x is used to specify an XCT file name that differs from the project name, 
<project_name>.xct

-ppnOnly is used to override all of the above parameters. When using ppnOnly, 
legacy2lci does not need a PRP and SYN file. The part name is derived from the 
PPN itself.

4. After the conversion process, make sure that the converted LCI file is in your working 
project directory.

5. In ispLEVER, choose File > Open to open your Project File (.syn).

NOTES • The ppnOnly option is case-sensitive. You must type the ppnOnly 
option exactly as shown.

• For ispLSI 1000 and 2000 devices, the part name defined in 
<project_name>.syn will be used; therefore, the part name defined 
in PAR file will be ignored. 
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ispLSI Legacy Constraints Support

The tables on the following pages list the ispLSI legacy constraints support in the new release.

NOTES • After you translate mappable constraints using the legacy2lci utility, 
you must resynthesize your design with your ispLEVER synthesis tool. 
You cannot import legacy EDIF files that were synthesized in 
ispDesignEXPERT 8.x directly into ispLEVER. 

• For legacy schematic designs, you may need to map old library 
symbols to equivalent new library symbols in ispLEVER after using 
the legacy2lci utility. Contact Lattice Technical Support for help with 
mapping old library schematic symbols with new library schematic 
symbols. 
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ispEXPLORER

The ispEXPLORER (Figure 17) lets you run multiple passes of your design using different 
combinations of Fitter/Optimizer settings and critical timing constraints to achieve the best solution. 
Results are summarized in a single spreadsheet and detailed reports for each run are accessible. The 
ispEXPLORER supports ispMACH 4000B/C, ispMACH 5000VG, and ispMACH 5000VE devices 
only.

Figure 17.  ispEXPLORER

The ispEXPLORER software helps you select the best constraint settings for your design by letting you 
run the design repeatedly with varied settings. The software gives you a single spreadsheet summary of 
results and settings after completion, making it easy to compare one group of settings with another. You 
can export the spreadsheet data into a Comma Delimited File (.csv) that you can import into a Microsoft 
Excel spreadsheet.
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Use Predefined or Customized Settings

You can create a single run or multiple runs using different combinations of settings. When you accept 
the settings for the predefined files, which is the initial default setting, the software automatically 
creates a run for each of the .lci files using the predetermined settings. When you use customized 
settings, you can change each of the values. You can also select multiple values for each setting and 
have the software keep running the design until it has exhausted all possible combinations among the 
selected values or until it has reached a specified run stop threshold. 

The predefined files are specially designed to give you the best Fmax or Tpd performance for the selected
device.

Create Multiple Versions of Design Runs

You can create multiple versions with different runs. Each time you click the Start button, you have the 
choice of creating a new version or overwriting an existing version. When you create a new version, the 
software creates a new version directory inside your project folder and copies the design files into this 
directory. It generates new constraint files based on the current project constraint file, plus the new 
settings you select, and runs the design using these settings. The results and settings for each run are 
then saved in subdirectories of the new version directory.

Save the Best Constraints For Your Project

After experimenting with different settings to determine which constraint settings are best for your 
design, you can save the constraints by using the Save Setting pop-up command for a specific run. 
When you save these constraints in ispEXPLORER, the software updates your project, replacing only 
the constraints that you have changed; it does not replace the .lci files.

Configuring Run Settings

You can configure a run setting or condition that will stop ispEXPLORER when your condition is met.
For example, you can set ispEXPLORER to stop when Fmax >=100MHz.

Reading Previous ispEXPLORER Runs

You can review previous runs of ispEXPLORER by opening the .epl file.
ispLEVER 1.0 Release Notes 27



ispUPDATE

The new ispUPDATE feature allows you to easily set up a proxy server to query the Lattice website for 
new software updates, device support, and enhancements. You can download patches and update files 
directly to your computer’s disk drive.

The ispUPDATE program lets you select the software version to be updated when there are multiple
versions of the software installed on the same computer. You can start the standalone ispUPDATE from
the Lattice program menu (Figure 18).

Figure 18.  Lattice Program Menu

For more details about ispUPDATE, refer to the Help Introduction section.
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New Version CAE Tools

The synthesis, RTL and timing simulation tools integrated in the ispLEVER have been upgraded to new 
versions.

� Synplicity Synplify: from v6.2.2 to v7.0.2A

� Mentor Graphics LeonardoSpectrum: from v1999.1j to v2002a.13_OEM_Lattice

� Mentor Graphics ModelSim: from v5.4e to v5.5e_p1

SVF File Generation

The ispLEVER installation program allows you to set the software to automatically generate Serial 
Vector Format (.svf) files. The three SVF files generated are:

� SVF_ERASE_PROGRAM_VERIFY (<project>_epv.svf). 
Svf_erase_program_verify specifies erase, program, and verify operations for the SVF 
file.

� SVF_ERASE_PROGRAM_VERIFY_SECURE (<project>_epvs.svf). 
Svf_erase_program_verify_secure specifies erase, program, verify, and secure operations 
for the SVF file.

� SVF_VERIFY_ONLY (<project>_v.svf). Svf_verify_only specifies verify only 
operation for the SVF file.

See the ispLEVER Installation Notice for details on how to set the software to automatically generate 
Serial Vector Format (.svf) files as a global setting.

If you do not set ispLEVER to generate SVF files during software installation, you can manually set the
options as a local setting in the Constraint Editor.

To manually set SVF file generation options:

1. In the Constraint Editor, click the Global Constraints Tab.

2. In the SVF_ERASE_PROGRAM_VERIFY, 
SVF_ERASE_PROGRAM_VERIFY_SECURE, and SVF_VERIFY_ONLY columns, 
select ON in the menu. The default of these three options is OFF.
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Checksum as USERCODE Default

The ispLEVER installation program allows you to set Checksum as the USERCODE default as global 
settings. See the ispLEVER 1.0 Installation Notice for details on how to set Checksum as the 
USERCODE default.

If you do not set ispLEVER to set Checksum as the USERCODE default during software installation,
you can manually set the option as a local setting in the Constraint Editor.

To manually set Checksum as the USERCODE default:

1. In the Constraint Editor, click the Global Constraints Tab.

2. In the Usercode_format column, select CHECKSUM in the menu. The default is OFF.

Updates to ispVM Programming Software

The ispVM programming software version 10.0.1A has new features, new device support, and software 
updates.

New Features

Added SVF Writer command line program (svf.exe) to support the ispLEVER software SVF file
creation.

New Device Support

The ispVM programming software version 10.0.1A has added support for ispMACH 5768VG device.

Software Updates

� The ispVM software version 10.0.1A has fixed "Read and Save JEDEC" and "Verify 
Only" operations for all MACH4A devices to prevent I/O glitching during "Read and 
Save" and Verify Only" operations. This is done by performing verification of the 
IDCODE followed by issuing a Bypass instruction to the device. Next, the UESRCODE 
of the device is read or verified depending on the operation. Finally, the device is enabled 
into programming mode to read or verify the device. When this is done, the I/O of the 
MACH4A will remain in HIZ during the entire "Read and Save" or "Verify Only" 
operations.

NOTE CHECKSUM option is not available for MACH 4 and MACH 5 devices.
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� The ispVM programming software version 10.0.1A has updated I/O BSCAN Vector 
Editor to support new package types.

� The ispVM programming software version 10.0.1A has updated ispVM command line 
support to return correct error codes.

� The ispVM programming software version 10.0.1A has write TDI(0) after HRD, TDR, 
HIR, AND TIR 0 in the SVF File.
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Known Issues and Solutions

The following known issues have been identified and their solutions are determined:

Legacy Constraints Conversions/Design Migration/Unified Constraint Editor 
Issues

Issue: You cannot mix Exemplar and Synplicity .ppn conversions. If you convert a 
Synplicity PPN file, the bus nomenclature uses a [] to enclose the components 
of the bus (i.e. - a[10]). The Exemplar PPN files uses the () to enclose the 
components of the bus (i.e. - a(10)). 

Solution: Don’t mix constraint files (.lci) that were created using different synthesis 
tools. 

Devices Affected: ispLSI 1000, 2000, and 8000

Issue: If you don’t import source constraints, PLL will not be recognized by the fitter.

Solution: When using a PLL in your design, you must import source constraints the first 
time the design is compiled.

Devices Affected: ispMACH 5000VG

Issue: When using the “Preserve” attribute for MACH devices, the report file does 
not show that the signals are preserved.

Solution: The property is working correctly, but it is not reported in the report file.

Devices Affected: All MACH devices
32 ispLEVER 1.0 Release Notes



Issue: The first line of VHDL code cannot be a commented line; it should be the 
library declaration.

Solution: Use library declaration for the first line of VHDL code.

Devices Affected: All

Issue: The following constraints specified in the Schematic Editor will not work:
PULL, SLOWRATE, OPENDRAIN, VOLTAGE, GROUP, RESERVE, CRIT, 
OUTDELAY.

Solution: Use the Constraint Editor to specify the constraints. 

Devices Affected: ispLSI 1000/2000/8000

Issue: Reserved pin assignments are not reported in the design summary section of 
the report file. 

Solution: None.

Devices Affected: MACH 5

Issue: When using PLLs in your design, prefit.exe will always generate a warning 
message regarding the removal of intermediate nodes associated with the PLL 
that are inserted by the synthesis tools. 

Solution: Ignore the warnings.

Devices Affected: ispMACH 5000VG

Issue: ispMACH 4A3/4A5, MACH 4/4A, and MACH 5/5LV devices support only 
ASCII format for USERCODE user constraint.

Solution: None. 

Devices Affected: ispMACH 4A3/4A5, MACH 4/4A, and MACH 5/5LV
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Issue: You cannot set both the GLB clock (CLK1, CLK2) and the IOC clock 
(IOCLK0, IOCLK1) in the Constraint Editor, for all the ispLSI 1000 devices. 
For example, to use one clock “GLB_IOC” to clock a register in both the GLB 
and IOC, the setting would be GLB_IOC=CLK1,IOCLK0. See page 10 of the 
1000EA Data Sheet to understand the clock matrix and this limitation.

Solution: You can set the clock in the ABEL source using the legacy ABEL attributes 
plsi PROPERTY 'CLK glb_io_clk clk1 ioclk0';

There is no solution for the Verilog and VHDL because the attributes are not 
supported in the source.

Devices Affected: ispLSI 1000/1000E/1000EA

ispVM Programming System Issues

Issue: The ISC compiler might report a false verify failure when using the ISC BSDL 
files. This may be a false failure due the speed improvements made to TCK, 
TDI, TMS, and TDO for our faster devices.

Solution: 1. Use the standard ispVM support, or;
2. Slow down the TCK clock by selecting Projects > Project Setting, and 
select Advanced button. In the TCK Clock pulse width in microseconds box, 
enter a value of 3 or greater.

Devices Affected: MACH 4/5
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Issue: The USERCODE support for ispLSI 8000, 8000V, 5000VA, 5000VE, 2000E, 
2000VE, 2000VL, 1000EA, ispGDX-V/VA family of devices was changed in 
version 9.0.4. The order the 32-bit USERCODE is programmed into the 
device, shifted out, and displayed in the ispVM GUI was changed to match the 
MACH device support. For these devices, the order the USERCODE bits are 
displayed in the GUI and the order they are written in the SVF file will match 
the order they are contained in the JEDEC file. For example, if the JEDEC file 
contains the following U field:

U00000001001000110100010101100111
     or:
         UH01234567

     The USERCODE will be programmed into the device as 0x01234567, the GUI 
will display the USERCODE as "0x01234567", and the USERCODE will be 
written in the SVF file as: SDR 32 TDI (01234567);

     Note: Devices programmed using ispVM V9.0.3 software, or earlier, will fail 
verify on V9.0.4 since the order they are programmed into the device has been 
swapped. To correct this error, reprogram the devices using ispVM V9.0.4 or 
later. The ispVM 9.0.4 software will fix the problem, as will later versions.

Note: Because of this change, these devices can no longer be cross verified 
with ispDCD. The ispDCD will report a verify failure on the Usercode. 

Solution: None

Devices Affected: ispLSI 8000, 8000V, 5000VA, 5000VE, 2000E, 2000VE, 2000VL, 1000EA, 
ispGDX-V/VA

Issue: When performing a SCAN CHAIN with ispVM, if an ID code is detected that 
is shared by multiple devices, ispVM will display a generic device name, and 
will give a warning.

Solution:  Select the correct device. 

Devices Affected: ispLSI 2032VE/VL, 2064VE(VL), 2064VE(VL)-44Pin, 2096VE(VL),  
2128VE(VL), 2128VE(VL)-100Pin, and 2192VE(VL)
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Online Help/Documentation Issues

Issue: If you install, uninstall, and re-install ispLEVER to a different location on your 
hard drive, you may receive an error message when you attempt to start Help. 
This can be caused by conflicts between the new location of Help and its old 
.gid file. GID files (help_file_name.gid) are configuration files that are 
dynamically created by Windows when starting Help, and contain the last 
location of the Help file. If the GID file is out of sync with the Help file (for 
example the GID file was not deleted during the uninstall process), you will 
receive a message saying that the Help file cannot be found 

Solution: Search for and delete all files with the extension .gid on your hard drive. 
Windows will automatically create a new GID file for each help system on 
your computer when you start the help system.

Devices Affected: All
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