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Copyright

This document may not, in whole or part, be copied, photocopied, reproduced, 
translated, or reduced to any electronic medium or machine-readable form without 
prior written consent from Lattice Semiconductor Corporation.

The software described in this manual is copyrighted and all rights are reserved by 
Lattice Semiconductor Corporation. Information in this document is subject to 
change without notice.

The distribution and sale of this product is intended for the use of the original 
purchaser only and for use only on the computer system specified. Lawful users of 
this product are hereby licensed only to read the programs on the disks, cassettes, or 
tapes from their medium into the memory of a computer solely for the purpose of 
executing them. Unauthorized copying, duplicating, selling, or otherwise distributing 
this product is a violation of the law.

Trademarks

Copyright (c) 2001 Lattice Semiconductor Corporation.

Lattice Semiconductor Corporation, L Lattice Semiconductor Corporation (logo), L 
(stylized), L (design), Lattice (design), LSC, Beyond Performance, E2CMOS, FIRST-
TIME-FIT, GAL, Generic Array Logic, In-System Programmable, In-System 
Programmability, ISP, ispATE, ispDesignEXPERT, ispDOWNLOAD, ispGAL, 
ispGDS, ispGDX, ispGDXVA, ispJTAG, ispLSI, ispMACH, ispPAC, ispSOC, 
ispSVF, ispTURBO, ispVIRTUAL MACHINE, ispVM, LINE2AR, MACH, MMI 
(logo), PAC, PAC-Designer, PAL, PALCE, Performance Analyst, Silicon Forest, 
Speedlocked, Speed Locking, SuperBIG, SuperCOOL, SuperFAST, SuperWIDE, 
UltraMOS, V Vantis (design), Vantis, Vantis (design), Variable-Grain-Block, and 
Variable-Length-Interconnect are either registered trademarks or trademarks of 
Lattice Semiconductor Corporation or its subsidiaries in the United States and/or 
other countries. ISP is a service mark of Lattice Semiconductor Corporation. 

GENERAL NOTICE:  Other product names used in this publication are for 
identification purposes only and may be trademarks of their respective companies.
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Lattice Semiconductor Corporation (LSC) products are made under one or more of 
the following U.S. patents:  4,130,889; 4,562,484; 4,635,230; 4,654,824; 4,654,825; 
4,608,678; 4,646,269; 4,684,826; 4,725,979; 4,742,247; 4,742,491; 4,758,747; 
4,761,768; 4,766,569; 4,771,285; 4,758,747; 4,779,229; 4,833,646; 4,852,044; 
4,855,954; 4,857,770; 4,876,640; 4,879,688; 4,887,239; 4,891,683; 4,896,296; 
4,933,897; 4,984,151; 4,994,691; 5,019,996; 5,081,380; 5,124,568; 5,128,871; 
5,130,574; 5,138,198; 5,151,623; 5,153,462; 5,162,679; 5,168,177; 5,185,706; 
5,189,322; 5,191,242; 5,191,243; 5,204,556; 5,231,315; 5,231,316; 5,231,602; 
5,237,218; 5,245,226; 5,247,213; 5,251,169; 5,272,666; 5,281,906; 5,295,095; 
5,329,179; 5,331,590; 5,336,951; 5,353,246; 5,357,156; 5,359,573; 5,394,033; 
5,394,037; 5,404,055; 5,412,260; 5,418,390; 5,438,277; 5,452,229; 5,493,205; 
5,506,517; 5,510,738; 5,521,529; 5,565,794; 5,570,046; 5,574,678; 5,583,451; 
5,586,044; 5,594,687; 5,596,524; 5,604,370; 5,617,064; 5,635,855; 5,646,901; 
5,666,087; 5,666,309; 5,670,907; 5,672,521; 5,679,599; 5,700,698; 5,719,516; 
5,742,542; 5,751,163; 5,754,471; 5,761,116; 5,789,269; 5,796,295; 5,796,750; 
5,809,522; 5,830,795; 5,835,405; 5,841,701; 5,854,114; 5,864,486; 5,869,981; 
5,886,378; 5,912,550; 5,960,274; 5,969,992; 5,982,193; 5,990,702; 5,999,449; 
6,023,570; 6,028,758; 6,028,789; 6,031,365; 6,034,541; 6,034,544; 6,034,893; 
6,038,789; 6,043,969; 6,064,105; 6,064,595; 6,066,977; 6,067,252; 6,072,351; 
6,075,293; 6,075,724; 6,081,473; 6,087,696; 6,087,854; 6,091,595; 6,093,946; 
6,097,212; 6,097,664; 6,100,715; 6,102,963; 6,104,207; 6,107,823; 6,118,693; 
6124,730 US. LSC does not represent that products described herein are free from 
patent infringement or from any third-party right.

The specifications and information herein are subject to change without notice. 
Lattice Semiconductor Corporation (LSC) reserves the right to discontinue any 
product or service without notice and assumes no obligation to correct any errors 
contained herein or to advise any user of this document of any correction if such be 
made. LSC recommends its customers obtain the latest version of the relevant 
information to establish, before ordering, that the information being relied upon is 
current.

LSC warrants performance of its products to current and applicable specifications in 
accordance with LSC’s standard warranty. Testing and other quality control 
procedures are performed to the extent LSC deems necessary. Specific testing of all 
parameters of each product is not necessarily performed, unless mandated by 
government requirements.

LSC assumes no liability for applications assistance, customer’s product design, 
software performance, or infringements of intellectual property rights arising from the 
use of the products and services described herein.
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LSC products are not designed, intended, authorized, or warranted for use as 
components in systems intended for surgical implant in the body, or in other 
applications intended to support or sustain life, or in any other application in which 
the failure of LSC’s product could create a situation where personal injury, death, or 
severe property or environmental damage may occur. Inclusion of LSC products in 
such applications is prohibited.

This legal notice is updated from time to time and users are advised to check the most 
current notice, which is available at www.latticesemi.com.

LATTICE SEMICONDUCTOR CORPORATION
5555 Northeast Moore Court

Hillsboro, Oregon 97124  U.S.A.
Tel.: (503) 268-8000
FAX: (503) 268-8347

http://www.latticesemi.com

April 2001

Limited Warranty

Lattice Semiconductor Corporation warrants the original purchaser that the Lattice 
Semiconductor software shall be free from defects in material and workmanship for a 
period of ninety days from the date of purchase. If a defect covered by this limited 
warranty occurs during this 90-day warranty period, Lattice Semiconductor will 
repair or replace the component part at its option free of charge.

This limited warranty does not apply if the defects have been caused by negligence, 
accident, unreasonable or unintended use, modification, or any causes not related to 
defective materials or workmanship.

To receive service during the 90-day warranty period, contact Lattice Semiconductor 
Corporation at:

Phone: 1-800-LATTICE or (408) 826-6022
E-mail: techsupport@latticesemi.com

If the Lattice Semiconductor support personnel are unable to solve your problem over 
the phone, we will provide you with instructions on returning your defective software 
to us. The cost of returning the software to the Lattice Semiconductor Service Center 
shall be paid by the purchaser.
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Limitations on Warranty

Any applicable implied warranties, including warranties of merchantability and 
fitness for a particular purpose, are hereby limited to ninety days from the date of 
purchase and are subject to the conditions set forth herein. In no event shall Lattice 
Semiconductor Corporation be liable for consequential or incidental damages 
resulting from the breach of any expressed or implied warranties.

Purchaser’s sole remedy for any cause whatsoever, regardless of the form of action, 
shall be limited to the price paid to Lattice Semiconductor for the Lattice 
Semiconductor software. 

The provisions of this limited warranty are valid in the United States only. Some 
states do not allow limitations on how long an implied warranty lasts, or exclusion of 
consequential or incidental damages, so the above limitation or exclusion may not 
apply to you.

This warranty provides you with specific legal rights. You may have other rights 
which vary from state to state.
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Preface

This user manual describes the capabilities and use of the ispVM™ System software. 
It is written for design engineers who understand system and logic design and the use 
of design automation software. You should also understand how to perform basic 
procedures using your operating system.

What is in This User Manual
This user manual contains chapters on the following topics:

■ Overview of the software

■ Procedures describing how to use the ispVM System software

■ Procedures describing how to use the SVF Debugger software

■ Description of the ispVM System software user interface

■ Description of the SVF Debugger user interface

■ Description of the ispVM command line mode

Where to Look for Information
Chapter 1, “Introduction” – Provides conceptual information about the ispVM 
System software.

Chapter 2, “The ispVM System Software” – Describes how to use ispVM System 
software to create and edit Chain Configuration Files.

Chapter 3, “The SVF Debugger” – Describes how debug and edit Serial Vector 
Format (SVF) files.

Appendix A, “Using the ispVM System GUI” – Describes how to use the ispVM 
System software Graphical User Interface.
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Chapter B, “Using the SVF Debugger GUI” – Describes how to use the SVF 
Debugger software Graphical User Interface.

Chapter C, “ispVM Command Line Mode” – Describes how to use the ispVM 
System Software using command line mode.

Related Documentation
In addition to this user manual, the following documentation is useful when using the 
Lattice Semiconductor ispVM System software:

■ ispDesignEXPERT User Manual 

■ ispDesignEXPERT Installation Notice

■ ISP Encyclopedia

■ ISP Daisy Chain Download User Manual (PC only)

■ ispDOWNLOAD Cable Reference Manual

■ Lattice/VantisPRO Application Note

These documents are located in the ..\software\manuals directory on the CD-
ROM. The ISP Encyclopedia is located in the ..\databook directory. These 
documents can be downloaded to a local drive or accessed on the CD-ROM.

Documentation Conventions
This user manual follows the typographic conventions listed here: 

Convention Definition and Usage

Italics Italicized text represents variable input. For example:

filename.svf

This means you must replace filename with the file name you used for all the 
files relevant to your design.

Valuable information may be italicized for emphasis. Book titles also appear in 
italics. 

The beginning of a procedure appears in italics. For example:

To scan the device chain:

Bold Valuable information may be boldfaced for emphasis. Commands are shown in 
boldface. For example:

1. Choose Configuration ⇒  Output to open the Output dialog.
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Documentation Conventions
Courier Font Monospaced (Courier) font indicates file and directory names and text that the 
system displays. For example:

In the ..\examples\ispLSI_GAL\clock directory, select ...

“Quotes” Titles of chapters or sections in chapters in this manual are shown in quotation 
marks. For example: 

See Chapter 1, “Introduction.”

✍  NOTE Indicates a special note.

⇒ Indicates a menu option leading to a submenu option. For example:

File ⇒ Import

Convention Definition and Usage
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Chapter 1 Introduction

This chapter introduces the ispVM™ System software. Included in this chapter are 
system and software requirements and conceptual descriptions of the ispVM System 
software. Included in this chapter are sections describing:

■ System Requirements

■ Installing ispVM System Software

■ About the ispVM System Software

■ Programming Basics

■ JTAG Scan Chains

■ Programming Algorithm Basics

■ Programming Times

■ USERCODE

■ I/O States During Programming

■ Programming Hardware

■ Programming Software
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Introduction
System Requirements:
■ PC running Microsoft Windows 95, Windows 98, Windows 2000, or Windows 

NT 4.0 or greater.

■ Parallel Port

■ Parallel Port Driver (for Windows NT and Windows 2000)

■ Lattice ispDOWNLOAD Cable or Vantis Cable

Installing ispVM System Software
The ispVM System software is automatically installed when you install 
ispDesignEXPERT. Refer to the “ispDesignEXPERT Installation Notice” for 
information about installing the entire suite of ispDesignEXPERT software, including 
the ispVM System software. You will be given the option of installing a parallel port 
driver for Windows NT and Windows 2000, which is required for programming 
devices with ispVM System software, during ispDesignEXPERT installation.

About the ispVM System Software
The ispVM System software is a comprehensive design download package that 
provides an efficient method of programming ISP devices using JEDEC files 
generated from Lattice Semiconductor software tools. This complete device 
programming tool allows you to quickly and easily download your designs to your 
devices. 

The ispVM System software supports both serial and concurrent (turbo) 
programming of all Lattice devices in a PC environment, and is built around a 
graphical user interface. Device chains can be scanned automatically. Any required 
JEDEC files are selected by browsing with a built-in file manager. 

Non-Lattice devices that are compliant with IEEE 1149.1 can be bypassed once their 
instruction register length is defined in the chain configuration file (.xcf). Using 
Lattice’s ispVM System software, programmable devices from other vendors can be 
programmed through the vendor-supplied SVF file.

Once the design has been compiled to a JEDEC file and device programming is 
necessary, the fuse map data must be serially shifted into the device along with the 
appropriate addresses and commands. 

Traditionally, programmable logic devices have been programmed on PLD/PROM 
programmers, so the programmer generates all the programming signals and 
algorithms. The programmer also generates the external super voltage or high voltage 
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required by non-ISP devices (typically 12-14 volts). This super voltage requirement is 
one of the reasons dedicated programmers are used to program conventional PLDs.

With In-System Programmable (ISP™) devices, the ISP programming super voltage 
is generated within the device from the power supply. Lattice ISP devices use 
nonvolatile electrically erasable (E2) CMOS technology and require only Vcc-level 

programming signals. An integrated state machine controls the sequence of 
programming operations such as identifying the ISP device, shifting in the 
appropriate data and commands and controlling internal signals to program and erase 
the E2 cells in the device. Programming consists of serially shifting the logic 
implementation stored in a JEDEC file into the device along with appropriate 
addresses and commands, programming the data into the E2 CMOS logic elements, 
and shifting the data from the logic array out for device programming verification.

Most of Lattice’s devices use the IEEE 1149.1-1993 Boundary Scan Test Access Port 
(TAP) as the primary interface for in-system programming. 

Programming Basics
To successfully program devices in-system, devices on the board must be correctly 
connected into an 1149.1 scan chain. This scan chain can be used for either 
programming or testing the board. To program using the ispVM System software, a 
description of the scan chain needs to be developed. This description is called a chain 
configuration file (.xcf) and contains basic information about all of the devices in the 
chain. For the Lattice devices, this includes the device type, the operation to be 
performed and the JEDEC file, if required by the operation. Additional information in 
the chain configuration file can include the state of the I/O pins during programming, 
along with security requirements and user options. If non-Lattice devices are present 
in the chain, the instruction register length is required for these devices. The 
instruction register length can be found from the BSDL file or the SVF file for the 
device.

Another requirement for successful programming is thoughtful board design. The 
signals used in a scan chain (TCK, TMS, TDI, and TDO) rarely operate as fast as the 
data path signals on the board. However, correct board layout methodologies such as 
buffering for large chains, termination resistors, etc. are required to ensure trouble-
free operation. Some Lattice devices have some additional pins (TRST, ENABLE, 
ispEN, bscanEN, EPEN and TOE) that can affect boundary scan programming and 
test if not taken care of properly.
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After these requirements have been met, it should be relatively straightforward to 
program any number of devices on a board. This programming can be done using a 
PC with either: 

■ A Lattice ispDOWNLOAD cable with the 8-pin AMP connector or the 10-Pin 
JEDEC connector attached to the board, and a board test system

■ A Vantis cable

JTAG Scan Chains
A scan chain can include any IEEE-1149.1 compliant, programmable or non-
programmable device. It can also include any programmable devices that are 
compatible with IEEE-1149.1 but do not have a boundary scan register. This is a 
decision that should be made based on the test methodology being employed for the 
board. If the test methodology employed is the traditional bed-of-nails approach used 
on board test systems, all the devices can be included in the same chain.

All scan chains use the simple four-wire TAP. The TCK and TMS pins are common to 
all devices included in the chain. TDI and TDO are daisy-chained from one device to 
the next. The input to the chain is TDI and the output from the chain is TDO. A 
diagram demonstrating a simple scan chain is shown in Figure 1-1.

Figure 1-1.  Example JTAG Scan Chain
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Programming Algorithm Basics
Programming a CPLD is similar to programming any piece of memory such as an 
EPROM or FLASH memory. The device can be thought of as an array that is 
programmed one row at a time. The programming information is provided to the 
software in the form of a standard JEDEC file that needs to be converted into the row 
and column fuse map data. Before an EEPROM device can be programmed, it first 
has to be erased. After the device has been erased, the programming data can be 
loaded and the device programmed. After the device has been programmed, it will be 
verified by reading out the data in the device and comparing it against the original. 

Figure 1-2 shows the basic programming flow for the device. It does not include 
JEDEC file data conversion into fuse map data, as it assumes that has already been 
done. This programming flow will be the same regardless of the programming 
hardware used. The primary difference between programming on different hardware 
platforms (PC vs. Workstation) is the type of hardware (parallel port vs. serial port) 
and the driver associated with it.
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Figure 1-2.  Programming Routine Flow
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Programming Times
The time it takes to program a device can often be a determining factor of where in 
the manufacturing process a device, or group of devices, is programmed. A board test 
system costing hundreds of thousands of dollars to purchase and costing as much as 
one dollar per minute to operate can be an expensive alternative for programming if 
programming times are too long. In many instances, it is more cost effective to buy a 
couple of PCs and program the devices using these much cheaper systems.

The time it takes to completely program a device is based on the time it takes to first 
erase the device, then program each row in the device, and then finally to verify the 
device. The erase time for all devices is between 100 and 200ms. A single row is 
programmed in 10 to 50ms, depending on the device. The Verify process is the 
quickest of the required steps in the programming sequence and is mainly dependent 
on the time required to shift the verify data out of any given device.

To minimize the total programming time of a daisy chain of ISP devices, a 
programming method called Turbo ispDOWNLOAD™ can be used to program all 
the ISP devices in the chain concurrently. Turbo ispDOWNLOAD allows any number 
of ISP devices to be programmed at the same time. When programming a chain 
concurrently, the chain can be programmed in the time it takes to program only the 
largest device plus some extra time in order to shift instructions and data for multiple 
devices. For example, a chain of three devices with programming times of 10, 7, and 
7 seconds can be programmed with Turbo ispDOWNLOAD in a total of about 10 
seconds (the time it takes to program the largest device). Serially, the programming 
time would be 24 seconds for all three devices. Turbo ispDOWNLOAD is 
incorporated into the ispVM software. This valuable feature of Lattice device 
technology is not available with many other ISP CPLD device technologies. 

The benefit of minimal programming times will be much more obvious on board test 
systems because they are included as a part of the test program and are running at the 
fastest speed possible. Additionally, there is no translation needed to or from JEDEC 
formatted data as this has already been done by the ispVM System software.

USERCODE
User-programmable identification can ease problems associated with document 
control and device traceability. The ispLSI 1000EA, 2000E, 2000VE, 2000VL, 
2000V, 5000V, 8000/V, MACH 4/A, ispGDX/A and ispGDXV families contain a 32-
bit register accessible through the optional IEEE 1149.1 USERCODE instruction. 
This user-programmable ID register is basically a user’s “notepad” provided in 
electrically erasable (E2) cells on each device.
ispVM System User Manual 1-7



Introduction
In the course of system development and production, the proliferation of PLD 
architectures and patterns can be significant. To further complicate the record-keeping 
process, design changes often occur, especially in the early stages of product 
development. The task of maintaining which pattern goes into what device for which 
socket becomes exceedingly difficult. Once a manufacturing flow has been set, it 
becomes important to “label” each PLD with pertinent manufacturing information, 
which is beneficial in the event of a customer problem or return. A USERCODE 
register is incorporated into ISP devices to store such design and manufacturing data 
as the manufacturer’s ID, programming date, programmer make, pattern code, 
checksum, PCB location, revision number, and/or product flow. This assists users 
with the complex chore of record maintenance and product flow control. In practice, 
the user-programmable USERCODE register can be used for any of a number of ID 
functions.

Within 32 bits available for data storage, users may find it helpful to define specific 
fields to make better use of the available storage. A field may use only one bit (or all 
bits), and can store a wide variety of information. The possibilities for these fields are 
endless, and their definition is completely up to the user.

Even with the device’s security feature enabled, the USERCODE register can still be 
read. With a pattern code stored in the USERCODE register, the user can always 
identify which pattern has been used in a given device. As a second safety feature, 
when a device is erased and re-patterned, the USERCODE identification is 
automatically erased. This prevents any situation in which an old USERCODE might 
be associated with a new pattern.

It is the user’s responsibility to update the USERCODE when reprogramming. It 
should be noted that the USERCODE information will not be included in the fuse 
map checksum reading.

Loading of the USERCODE instruction makes the USERCODE available to be 
shifted out in the Shift-DR state of the TAP controller. The USERCODE register can 
be read while the device is in normal functional operation, allowing the device to be 
scanned while operating.

I/O States During Programming
During a programming cycle, all ispJTAG devices default to having their I/Os tri-
stated. In most situations, this probably will be acceptable and will not cause any 
problems. However, there are situations that arise where it may cause some 
contention. Through the boundary scan cells of Lattice devices, the ispVM System 
software offers the ability to set all I/O pins to a state of “1”, “0”, HIGHZ, or don’t 
care, and to set the state of each I/O pin individually.
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Programming Hardware
All ISP programming specifications such as the programming cycle and data 
retention are guaranteed when programming ISP devices over the commercial 
temperature range (0 to 70o C). It is critical that the programming and bulk erase 
pulse width specifications are met by the programming platform to insure proper in-
system programming. The details of device programming are transparent to the user if 
Lattice ISP programming hardware and software are used.

PC Hardware

Programming is most commonly done on a PC through a download cable attached to 
the parallel port using the ispVM System software.

ispDOWNLOAD Cable

The ispDOWNLOAD cable is designed to facilitate in-system programming of all 
Lattice ISP devices on a printed circuit board directly from the parallel port of a PC. 
The ispVM System software generates programming signals directly from the parallel 
port of a PC, which then pass through the ispDOWNLOAD cable to the device(s). 
With this cable and a connector on the board, no additional components are required 
to program a device. Refer to the ispDOWNLOAD Cable Data Sheet, available in the 
Lattice/Vantis Data Book, for more detailed specifications and ordering information.

Hardware design considerations for new boards include whether the hardware 
designer will be using boundary scan test operations or low voltage (3.3V) devices. In 
a system using 3.3V ISP devices, the ispDOWNLOAD cable version 2.0 should be 
used. The cable operates with either a 3.3V or 5V Vcc source.

ISP Engineering Kit Model 300

The ISP Engineering Kit Model 300 provides designers with a quick and inexpensive 
means of evaluating and prototyping new designs using Lattice devices when 
compared to a standalone programmer. This kit is designed for engineering purposes 
only and is not intended for production use. The kit programs devices from the 
parallel printer port of a host PC. By connecting a system cable (included) from the 
host PC to the ISP Engineering Kit with the proper socket adapter, a device can be 
easily programmed using the ispVM System software. See Figure 1-3.
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Figure 1-3.  ISP Engineering Kit Model 300
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Programming Software
Programming on a Board Test System

Programming on a board test system is made possible by using the ATE feature to 
generate the necessary programming files needed for the different platforms. The 
platforms supported include GenRad, Hewlett Packard, and Teradyne board test 
systems. A generic JEDEC vector format is generated to help support any ATE not 
directly supported.

Programming on JTAG Test Systems

JTAG test systems differ from traditional board test systems in their basic test 
methodology. These systems use only the four wire JTAG TAP to perform any 
interconnect and functional tests. A simple language has been developed to interface 
with the TAP and is used by most major JTAG test system vendors. This language is 
known as the Serial Vector Format (SVF) and is supported by the ispVM System 
software. Current SVF specifications are available from the Asset-Intertech website at 
www.asset-intertech.com.

Embedded Programming

The ispVM embedded source code is available for programming devices in an 
embedded or customized environment. The programming source code is written in 
ANSI-standard C language and can be easily incorporated into embedded system or 
tester software to support programming of ISP devices. This code supports such 
common operations as Program, Verify, Erase, and Secure. After completion of the 
logic design and creation of a JEDEC file(s), the ispVM System software creates the 
data files required for in-system programming on customer-specific hardware: PCs, 
testers, or embedded systems.
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Chapter 2 The ispVM System Software

The ispVM System software allows you to program Lattice devices with a download 
cable using a PC running Windows 95, Windows 98, Windows 2000, or Window NT 
operating system. The ispVM System Software also includes the SVF Debugger 
software, which allows you to debug Serial Vector Format (SVF) files. The SVF 
Debugger Software is described in more detail in Chapter 3, “The SVF Debugger”.

This chapter describes in detail how to use the ispVM System software. Included in 
this chapter are sections that describe:

■ How to start the ispVM System software

■ Getting started using the ispVM System software

■ Editing Chains and Devices

■ Setting the User Environment

■ Changing ispVM System Software Settings

■ Using ispVM System Software Utilities

■ Setting ispVM System Software Options
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Starting ispVM System Software
To start the ispVM System software, choose the Start menu. In the Start menu, select 
the menu item Programs ⇒  Lattice Semiconductor ⇒ ispVM system to open the 
ispVM System window (Figure 2-1). You can use the pull-down menus or the tool bar 
icons to perform various functions needed to download JEDEC files to the devices in 
the chain.

Figure 2-1.  ispVM System Window

Getting Started
When you start the ispVM System software for the first time, you must create a new 
project, or chain configuration file (.xcf). After that, ispVM System starts with the last 
project that was open. There are four ways to create a chain configuration file:

■ Create a new chain configuration

■ Open an existing chain configuration file

■ Import an ISP or LatticePRO file

■ Scan a device chain
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Creating a New Chain Configuration

There are several ways you can start a new chain configuration. One way is to create 
a new chain configuration file (.xcf) and add devices.

To create a new chain configuration file:

1. Choose File ⇒  New. The ispVM System software opens an empty chain 
configuration window (Figure 2-2).

2. Choose Edit ⇒  Add Device to add devices to the new chain file as needed.

Figure 2-2.  Single Chain Configuration Window and Status 
Window

✍  NOTE For more information about the ispVM System software 
Graphical User Interface (GUI), refer to Appendix A, “Using 
the ispVM System GUI”.
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Opening an Existing Chain File

You can open an existing configuration file (.xcf) with the ispVM System Software. 
The daisy chain configuration must be the same as that for which the chain 
configuration file (.xcf) was created. Each unique chain configuration requires a 
unique chain configuration file.

To open an existing configuration file:

1. Choose File ⇒  Open to open the Open XCF File dialog.

2. Use the dialog to locate and select the desired XCF file, and then click Open. 
The selected configuration file opens in a new Chain Configuration window.

Importing an ispDCD or LatticePRO File

You can import an existing ispDCD download configuration file (.dld) or LatticePRO 
download configuration file (.wch) with the ispVM System Software using the 
Import command.

To import an existing ispDCD or LatticePRO configuration file:

1. Choose File ⇒  Import to open the Open Import File dialog.

2. Use the dialog to locate and select the desired file, and then click Open. The 
selected configuration file opens in a new Chain Configuration window.

Scanning a Device Chain

You can scan the device chain on the board connected to your PC with a download 
cable to start a new chain configuration.

To scan the device chain:

■ Choose ispTools ⇒  Scan Chain. The ispVM System software opens a new chain 
configuration file (.xcf), scans the printed circuit board properly connected to 
your computer with a download cable, and lists the devices in the new chain file. 
You can also use this method for scanning a mixed chain using the ispTools ⇒  
Scan Mixed Chain.

✍  NOTE You must assign a JEDEC file to the devices in the chain 
configuration file, as well as possibly editing other device 
information, to have a “valid” chain file.
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Editing Chains and Devices
You can edit device chain configuration with the ispVM System software. You can:

■ Add a new device chain

■ Remove a device chain

■ Add a device to a device chain

■ Remove a device from a device chain

■ Edit device information

■ Move a device up or down in the chain

■ Reverse the order of devices in the chain

Adding a New Device Chain

You can add another chain to a chain configuration file (.xcf) to create a mixed JTAG 
and ISP chain configuration. You do this by first adding a mark (chain mark) to 
indicate the beginning of the new chain, as shown in Figure 2-3.

Figure 2-3.  Mixed Chain Configuration

To add a new device chain to an existing chain configuration file:

1. Select the last device in the existing chain. You cannot add a new chain to the 
middle of another chain.

2. Choose Edit ⇒  Add Chain Mark to add the chain mark. 

3. Choose Edit ⇒  Add Device to create the new chain.
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Removing a Device Chain

The ispVM System software lets you have two chains in the same chain configuration 
file (.xcf). Sometimes you will want to remove a chain from a chain configuration 
file. You might think that you could just select the chain mark and delete it. However, 
to remove a device chain you have to delete all the devices in the chain—one by 
one—and then delete the chain mark.

To remove a device chain:

1. Select a device in the chain that you want to remove.

2. Choose Edit ⇒  Delete Device to delete the selected device.

3. Repeat the above step until you have deleted all the devices from the chain that 
you want to remove.

4. In the configuration file, select the Chain Mark.

5. Choose Edit ⇒  Delete Chain Mark.

Adding a Device to a Device Chain

You can add devices to an existing chain using the Device Information dialog.

To add a device:

1. Select the device directly above the position of the device that you want to add.

2. Choose Edit ⇒  Add Device to open the Device Information dialog (Figure 2-4).
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3. Complete the requested information on the dialog and then click OK. The 
software inserts the new device into the active chain, below the currently selected 
device, as specified in the Device Information dialog.

Figure 2-4.  Device Information Dialog

Table 2-1 describes the features of the Device Information Dialog.

Table 2-1.  Device Information Dialog Features

Feature Description

Select... Opens the Select Device dialog, which lets you select a device and its package 
that you want to add to the chain.

Part Description Allows user to enter comments for the device.

Device fullname Displays the name of the device that corresponds to the Device Number field. 
This field is enabled when you select the Build SVF file for single device 
option above.

Data File (*.JED) Use the Browse button to locate the JEDEC file that goes with the chosen part.

Instruction 
Register Length

Lets you specify the instruction register length by either importing it from the 
BSDL (.bsm or .bsd) file or the SVF file. You can also manually specify a 
value from 0-50. This option is available only when you select the JTAG-NOP 
device.

Package Displays the package description for the selected device. This field is 
automatically filled in when you select the device using the Select Device 
dialog.
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Table 2-2 describes the features of the Device Information Dialog Expanded Options.

Operation Lists the operation mode for each file. The default is Erase, Program & Verify. 

Table 2-2.  Device Information Dialog Expanded Options

Feature Description

TCK Frequency Lets you specify the clock frequency for the chosen device. This option is 
available for JTAG devices only.

SVF Vendor Let’s you choose the SVF vendor for the chosen device. Choices are:

• JTAG STANDARD

• LATTICE

• ALTERA

• XILINX

This option is available for JTAG devices only.

I/O State • I/O State

• Lets you specify the state of the I/O pins during programming. Choices are:

• HighZ

• All 1’s

• All 0’s

• Custom

• Leave Alone

I/O Vector File Lets you specify the location and name of the I/O Vector file. This field is 
available when you select the Custom I/O State option above.

BSDL File Lets you specify the location and name of the BSDL file. This field is 
available when you select the Custom I/O State option above.

Edit Lets you edit the I/O Vector file using the I/O Vector Editor.

Advanced Opens the Advanced Device Information dialog, which lets you specify 
advanced configuration parameters for the selected device.

Table 2-1.  Device Information Dialog Features (Continued)

Feature Description
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Removing a Device From a Device Chain

You can remove the currently selected device from the active chain file using the 
Delete Device command. There is no undo for this command.

To remove a device:

1. Select the device that you want to delete.

2. Choose Edit ⇒  Delete Device.

Editing Device Information

You can change various information about a device in the chain using the Device 
Information dialog.

To edit device information:

1. Select the device that you want to edit.

2. Choose Edit ⇒  Edit Device to open the Device Information dialog.

3. In the dialog, change the device information that you want and then click OK.

Moving a Device Up or Down

You can change the position of a device up or down, one position at a time.

To move a device up:

1. Select the device that you want to move.

2. Choose Edit ⇒  Move Device Up to move the device up one position in the 
chain.

To move a device down:

1. Select the device that you want to move.

2. Choose Edit ⇒  Move Device Down to move the device down one position in the 
chain.

Reversing the Order of Devices

If you get the input device confused with the output device, the ispVM System 
software gives you an easy way to correct this by reversing the order of the devices in 
the chain with the Reverse Chain Order command.
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To reverse the order of devices:

■ Choose Edit ⇒  Reverse Chain Order.

Setting Chain Operations

The ispVM System software lets you choose from several chain operations for each 
device in the chain.

To set a chain operation in a device:

1. Select the device that you want to set the operation.

2. Choose Edit ⇒  Set Chain Operations, and then choose the specific operation 
for the device.

Setting Advanced Device Parameters
You can use the Advanced Device Information dialog to specify advanced 
configuration parameters for the selected device that you are adding to a device chain. 
You can open the Advanced Device Information dialog by clicking the Advanced 
button of the Device Information dialog. Refer to “Adding a Device to a Device 
Chain” for information about opening the Advanced Device Information dialog.

Figure 2-5.  Advanced Device Information dialog
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Table 2-3 describes the features of the Advanced Device Information dialog.

Overriding Device Operations

You can use the Project Setting dialog to override the operations in a chain file. The 
advantage to this method as opposed to “changing” the operation using the Device 
Information dialog or the Set Chain Operations command is that you can easily 
restore the chain file to its original operation settings.

To override device operations:

1. With a chain file open, choose Project ⇒  Project Settings to open the Project 
Setting dialog (Figure 2-6).

2. Under Operation Override, select the operation that you want to be the overriding 
operation.

3. Click OK. Notice that the operation descriptions for all the devices in the chain 
file are now set to the overriding operation.

If you selected Entire Chain, when you download the file all of the devices will 
use the overriding operation.

Table 2-3.  Advanced Device Information Dialog Features

Feature Description

Re-initialize part... When selected, the software will erase the device if programming failed.

BYPASS Options Lets you specify the BYPASS instruction for the selected device.

SVF Options Lets you choose which SVF processor the ispVM System software will use 
when running the SVF file.

If you select ispVM, the SVF file is compiled and will run faster. If you select 
the SVF Interpreter, each line is interpreted and processed one line at a time 
and will run slower. In either case, the end result will be the same.

Override 
USERCODE/
UES...

Lets you override the USERCODE/UES value in the JEDEC file with the 
value in the field below.

Max Bits/Digits Displays the maximum number of bits/digits you can enter in the 
USERCODE/UES field, shown above.

Auto-Increment... Lets you specify the incremental step (0-100) for the USERCODE/UES after 
successful programming.
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If you selected Selected Device, when you download the file only the selected 
device will use the overriding operation.

4. To restore the original operations, choose Project ⇒  Project Settings to open 
the dialog again.

5. Under Operation Override, select No Override.

6. Click OK. A message asks “Do you want to reload the original setup?”

7. Click Yes to restore the original settings in the chain file.

Figure 2-6.  Project Setting Dialog
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Table 2-4 describes the features of the Project Settings Dialog.

Table 2-4.  Project Settings Dialog Features

Feature Description

Turbo Program Programs all the devices on the board in parallel. If an Operation Override is 
selected, all Operation descriptions in the chain file are temporarily changed 
to the override setting. These process operations are supported:

• Erase, Program, Verify

• Erase, Program, Verify, Secure

• Program Only

• Verify Only

• Erase Only

• Bypass

Sequential 
Program

Programs all the devices on the board one at a time. If an Operation Override 
is selected, all Operation descriptions in the chain file are temporarily changed 
to the override setting. These process operations are supported:

• Erase, Program, Verify

• Erase, Program, Verify, Secure

• Program Only

• Verify Only

• Erase Only

• Bypass

• Calculate Checksum

• Display ID

• Display USERCODE

• Read and Save JEDEC

• Secure Device

Entire Chain Processes the entire chain with the operations specified in the chain 
configuration window.

Selected Device Processes the selected device with the operations specified in the chain 
configuration window.

Operation Override Lets you override the operations in the chain configuration window. You can 
restore the original operations by setting the Override Operation to No 
Override.
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Avoid Test Logic 
Reset State

Lets you specify that the ispVM System will avoid the Test Logic Reset State 
of the JTAG State Machine during download.

Continue 
Download Even on 
Error

Lets you specify that the ispVM System will ignore any errors while 
downloading and will continue running.

Contention 
Reduction (MACH 
Devices)

Lets you specify that the Boundary Scan Register will always drive the device 
I/O during download. This option causes the download speed to be slower. If 
your design can tolerate the I/Os from becoming temporary active for 1ms, 
you can ignore this setting. However, using this option does not avoid the I/O 
from becoming active at the beginning and end of the download process. 

("Active" refers to the period when the core logic of the user design is driving 
the I/Os.))

Starting TAP State Lets you specify the starting JTAG state of the JTAG State Machine for 
download. Only two states are available: TLR and RTI.

Ending TAP State Lets you specify the ending JTAG state of the JTAG State Machine for 
download. Only two states are available: TLR and RTI.

Advanced Opens advanced options for Project Settings dialog.

Optional JTAG 
Signal Connected

ISPEN/BSCAN – Indicates the device requires the signal. If required, you 
cannot disconnect the signal.

ISPEN/BSCAN pin disconnected – Lets you disconnect the signal

ISPEN/BSCAN pin connected - Lets you connect the signal

TMS - Indicates the device requires the signal.

TCK - Indicates the device requires the signal.

TDI - Indicates the device requires the signal.

TDO - Indicates the device requires the signal.

TCK Clock Pulse 
Width…

Lets you specify the TCK pulse width in microseconds.

Comment Lets you add comments to the chain file. There is no limit on the number of 
characters. 

Table 2-4.  Project Settings Dialog Features (Continued)

Feature Description
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Viewing the Status Window
The ispVM System software displays various feedback messages about your project 
in the Status window, which is located in the Single Chain Configuration Window and 
Status Window (Figure 2-2). 

After processing your chain configuration file, you can clear the contents of the Status 
window.

To clear the status window:

■ Choose Edit ⇒  Clear Status Window.

Viewing the Log File
You can use the View Log File command to open the project log file, which is an 
ASCII text report file summarizing the results of the ispVM System software 
operations.

To view the log file:

■ Choose Project ⇒  View Log File.

To clear the contents to the log file:

■ Choose Edit ⇒  Clear Log File.

Setting the User Environment
You can set the ispVM System software user environment to your preference. You 
can:

■ Customize the main window background

■ Set display font styles

Customizing the Main Window Background

You can customize the background of the ispVM System software main window by 
specifying a background graphic and setting various display options, as well as 
specifying a standard or custom background color.

To customize the background:

1. Choose View ⇒  Background to open the Background dialog (Figure 2-7).
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2. On the dialog, do the following:

• If you want to select a graphic for the background, click Browse.

• Select a Display setting for the graphic.

• If you want the graphic to be offset, set an X and Y value.

• If you want to specify a background color, click Back Color. Note that if 
you selected either Tile or Stretch as the Display setting, you will not be able 
to see the background color.

3. Click OK.

Figure 2-7.  Background Dialog

Table 2-5 describes the features of the Background Dialog Box.

Table 2-5.  Background Dialog Box Features

Feature Description

Background File 
Name

Browse for a file to use as a background graphic.

Browse Browse for a file to use as a background graphic.

Display Allows you to change the way the background graphics is displayed.

• Tile causes the background to be displayed repeatedly.

• Center centers the graphic in the window.

• Stretch streches the graphic to fit the window.

• Custom allows you to specify X and Y axis points to position the graphic.

X and Y Set an X and Y offset value for the background graphic, if one is specified. 
This parameter is available only when Custom display parameter is selected.

Default Returns the dialog to its default settings.
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Setting the Display Font Styles

You can specify the font, font style, and size of the font for text appearing in the 
Chain Configuration window.

To set display font styles:

1. Choose View ⇒  Font to open the Font dialog (Figure 2-8).

2. Choose the options you want, and then click OK.

Figure 2-8.  Font Dialog

Clear Clears the current user settings and sets the background color to gray. You 
must use this button to remove a background graphic.

Auto Save Automatically saves the current settings so they are available the next time 
you open the ispVM System software.

Back Color Opens the Color dialog, which lets you choose a basic or custom color for the 
background.

Table 2-5.  Background Dialog Box Features (Continued)

Feature Description
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Changing ispVM System Software Settings
You can specify how the ispVM System software will process the active chain 
configuration using the Project Setting dialog. For example, you can tell the ispVM 
System software to process the whole chain or only a single device, override selected 
operations of all the devices in the chain or the selected device, as well as other 
options. 

Setting ispVM System Process Characteristics
You can set ispVM System software process characteristics with the Project Settings 
dialog.

To specify ispVM System processing options:

1. Choose Project ⇒  Project Settings to open the Project Settings dialog.

2. Choose the options you want, and then click OK.

Checking the Configuration Status

You can use the Check Configuration Setup command to verify that each device has 
a .jed file attached and check the operation selection for each device. This command 
prints the configuration status (pass/fail) for each device in the configuration. A 
successful message appears in the Messages window.

To check the configuration status:

■ Choose Project ⇒ Check Configuration Setup.

Downloading Design Files

After you have specified all of the processing options, you can use the Download 
command to download the design files to the daisy-chained devices.

To download design files:

■ Choose Project ⇒  Download.
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Generating SVF and ATE Files
You can generate Serial Vector Format (SVF) files and GTE Files with ispVM System 
software. SVF files are ASCII files that stores programming data for programming 
one or more fixed algorithm devices in Automated Test Equipment (ATE)-type 
programming environments. ATE files are test files formatted for Genrad, HP, and 
Teradyne testers, as well as a Generic Vector format.

Generating an SVF File

SVF files allow you to exchange data between the Automated Test Equipment (ATE)-
type programming environment and the software driving it. You can use the Generate 
SVF File dialog to set options for building an SVF file, 

To generate an SVF file:

1. Choose Project ⇒  Generate SVF File to open the Generate SVF File dialog 
(Figure 2-9).

2. Choose the options you want, and then click OK.

Figure 2-9.  Generate SVF File Dialog
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Table 2-6 describes the features of the Generate SFV File Dialog.

Table 2-6.  Generate SVF File Dialog Features

Feature Description

Build SVF file for 
single device

Lets you generate an SVF file for a single device, as specified in the Device 
Number field below.

Build Sequential 
Chain SVF File

Lets you generate a single SVF file for the entire chain, programming each 
device sequentially.

Build Turbo Chain 
SVF File

Lets you generate a single SVF file for the entire chain, programming all the 
devices at one time. For a one-device chain, defaults to sequential mode.

Source File (*.xcf) Lets you specify the project file.

Save SVF File as: Lets you save the SVF to the specified name and location.

Device Number Lets you select a device in the chain for which you want to generate an SVF 
file. This field is enabled when you select the Build SVF file for single device 
option above.

Device Name Displays the name of the device that corresponds to the Device Number field. 
This field is enabled when you select the Build SVF file for single device 
option above.

Device Operation Displays the operation of the device that corresponds to the Device Number 
field. This field is enabled when you select the Build SVF file for single 
device option above.

JEDEC File Lets you select the JEDEC file that the ispVM System software will use to 
generate the SVF file. This field is enabled when you select the Build SVF file 
for single device option above.

Advanced Opens advanced options for Generate SVF File dialog.

Use RUNTEST... When selected, tells the ispVM System software to generate the SVF file 
using the format specified in the SVF file specification, revision C or earlier.

When Erase, 
Program, Verify...

When selected, globally skips the verification step of the Erase, Program, and 
Verify operation.

Write RESET in 
SVF file

When checked, writes STATE RESET at the beginning of the SVF file.
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Generating an ATE File

You can use the Generate ATE dialog to build a test file formatted for Genrad, HP, and 
Teradyne testers, as well as a Generic Vector format.

To generate an ATE file:

1. Choose Project ⇒  Generate ATE File to open the Generate ATE File dialog 
(Figure 2-10).

2. Choose the options you want, and then click OK.

Figure 2-10.  Generate ATE Dialog

Table 2-7 describes the features of the Generate ATE File Dialog.

Table 2-7.  Generate ATE File Dialog Features

Feature Description

Tester Type Lets you specify the target tester for the ATE file.

Source File Lets you specify the project file used to create the ATE vector files.
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Setting Advanced ATE Features
You can set advanced ATE features with the Advanced ATE Options dialog 
(Figure 2-11). You can open the Generate ATE Information dialog by clicking the 
Advanced button of the Generate ATE File dialog. Refer to “Generating an ATE 
File” for information about opening the Generate ATE File dialog.

Figure 2-11.  Advanced ATE Options

Output File Lets you specify the file name base (eight characters or less) that will be 
appended incrementally by the ATE generation process. For example, if you 
enter “vec” as the base name and 128 files are created, the file names will 
appear as vec0, vec1, vec2, etc. The dot extension depends on the ATE 
vendor.

Header File Lets you specify the name and location of the Header file. The header data can 
include the author name, the type of configuration setup that this header will 
appear with, pin definitions, signal names, timing information, etc. The 
ispVM System software will affix this header data to the head of each ATE 
vector file it generates.

Advanced Opens the Generate ATE Information dialog, which lets you specify the 
content and format of the ATE file.

Table 2-7.  Generate ATE File Dialog Features (Continued)

Feature Description
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Table 2-8 describes the features of the Advanced ATE Options Dialog.

Converting a JEDEC File to a ISC Data File
You can use the JEDEC to ISC Data File Converter dialog to convert JEDEC files 
(*.JED) to ISC Data files (*.ISC).

To convert a JED file to ISC File:

1. Choose Project > Generate ISC File to open the JEDEC to ISC Data File 
Converter dialog (Figure 2-12).

2. In the Device box, select device.

3. Ensure the entity name in the Entity Name box matches the entity name in the 
BSDL file of the selected device and package.

4. In the Data File (*.JED) box, select the JED file you wish to convert to ISC Data 
File.

Table 2-8.  Advanced ATE Options Dialog Features

Feature Description

Split file Allows the vector files to be split to reduce file size.

Split File without 
Initialization

Allows the vector files to be split to reduce file size. Pull down resistors on 
ispEN, MODE and SCLK are mandatory to use this option. 

Maximum number 
of vectors per file

Lets you specify the maximum number of vectors allowed in each vector file. 
This data can be obtained from the ATE vendor. The default setting of 0 builds 
one ispVECTOR file.

Program Vectors 
Only

When selected, skips the verification stage of the operation.

Erase Vectors Only When selected, creates an ATE file with the Erase operation only. This 
overrides individual device operation settings in the chain file.

Vector Signal 
Order

Lets you specify the signal order in each vector. You can use the Up and Down 
buttons to manually change the location of the selected signal.

Up / Down Moves the location of the selected pin up or down within the vector.

HP-PCF Data Shows initial programming pin names and vector read and write delay values. 
You can edit these values by typing the new value in each field.

More Opens mroe options for Advanced ATE Options dialog.
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5. In the ISC File (*.ISC) box, name and location of the ISC Data file that you wish 
to convert.

6. Click OK.

7. Click View to view the result of the conversion.

Figure 2-12.  JEDEC to ISC Data File Converter Dialog

Table 2-9 describes the features of the JEDEC to ISC Data File Converter dialog.

Table 2-9.  JEDEC to ISC Data File Converter Dialog Features

Feature Description

Device Lets you specify the device in the selected Device Family.

Entity Name Entity name for the selected device and package

Data File (*.JED) Use the Browse button to locate the JEDEC file that goes with the chosen part.

ISC File (*.ISC) Use the Browse button to locate the directory where you want to place the ISC 
file.

View Opens a text browser and allows you to view the resultant ISC file.
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Converting a Composite File to a JEDEC File
You can use the Convert Composite Files to JEDEC Files dialog (Figure 2-13) to 
convert Composite files (*.CMP) to JEDEC files.

To convert a CMP file to a JED file:

1. Choose ispTools > Convert Composite to JEDEC File to open the Convert 
Composite Files to JEDEC Files dialog.

2. In the Composite File (*CMP) box, select the CMP file you wish to convert to 
JED file.

3. In the JEDEC File (*.JED) box, enter name and location of the JED file you wish 
to convert.

4. Click Convert.

Device Family Lets you specify the device family:

• Generic JTAG - Non-Lattice device

• ispLSI

• ispGDS

• ispGDX

• ispGAL

• MACH

Device Lets you specify the device in the selected Device Family.

Package Displays the package description for the selected device. This field is 
automatically filled in when you select the device using the Select Device 
dialog.

Table 2-9.  JEDEC to ISC Data File Converter Dialog Features (Continued)

Feature Description
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Figure 2-13.  Convert Composite Files to JEDEC Files

Table 2-10 describes the features of the Convert Composite Files to JEDEC dialog.

Using ispVM System Software Utilities
The ispVM System software has numerous utilities, including:

■ SVF Interpreter

■ USERCODES/UES Editor

Using the SVF Interpreter

You can use the SVF Interpreter dialog (Figure 2-14) to specify the single device SVF 
file for processing by the SVF Interpreter. You can also open the SVF Debugger from 
this dialog. Refer to “The SVF Debugger” on page 3-1 for more information about the 
SVF Debugger.

Table 2-10.  Convert Composite Files to JEDEC Files features

Feature Description

Composite File 
(*.CMP)

Browse to Composite File (*.CMP).

JEDEC File 
(*.JED)

Browse to JEDEC File (*.JED).

Calculate JED 
Checksum only

Calculate checksum and write to JEDEC file.

Convert Click to Convert Composite File (*.CMP) to JEDEC File (*.JED).
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To open the SVF Interpreter dialog:

■ Choose ispTools⇒  SVF Interpreter.

Figure 2-14.  SVF Interpreter Dialog

Table 2-11 describes the features of the SVF Interpreter.

Table 2-11.  SVF Interpreter Dialog Features

Feature Description

Data File Lets you select the SVF file to process.

Disable SVF 
Syntax Checker

Disables tool that checks syntax of SVF file. 

Ignore IR and DR Ignores the header and trailer information of the Instruction Register and Data 
Register when processing the SVF file.

Continue on Error Continue processing the SVF file even if there is an error.

Mixed Chain Tells the SVF Interpreter that the hardware configuration is a mixed chain, 
therefore disabling the ISP chain when processing the SVF file.

Calculate JEDEC 
checksum

Calculate and return checksum from the SVF file.

Convert to JEDEC 
file

Convert the SVF file to a JEDEC file.  The resulting JEDEC file name is the 
same as the SVF, but with the *.jed extension.
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Using the USERCODE/UES Editor

You can use the ispVM System USERCODE/UES Editor to add information to your 
JEDEC file, such as serial code number, design code, or lot number. This information 
is written to the USERCODE/UES field (U), after the fuse map data. The signature 
must be in either decimal (0-9) or hexadecimal (A-F) characters.

To use the USERCODE/UES Editor:

1. Choose ispTools ⇒  USERCODE/UES Editor to open the USERCODE/UES 
Editor (Figure 2-15).

2. Navigate to the JEDEC file that you want to edit, select it, and then click Open. 
The editor opens with the selected .JED file.

Instruction 
Register Header

Set the IR header length in number of bits (1-100).

Instruction 
Register Trailer

Set the IR trailer length in number of bits (1-100).

Data Register 
Header

Set the DR header length in number of bits (1-100).

Data Register 
Trailer

Set the DR trailer length in number of bits (1-100).

TCK Frequency Set the TCK clock frequency (1-30 MHz). This value affects the processing 
speed of the SVF Interpreter.

Run Runs the SVF Interpreter.

Debug Opens the SVF Debugger. Refer to “The SVF Debugger” on page 3-1 for 
more information about the SVF Debugger.

Advanced Opens advanced options for SVF Interpreter dialog.

Table 2-11.  SVF Interpreter Dialog Features (Continued)

Feature Description
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3. Click Read. If there is no data in the field, you will see a string of 20 Fs 
(Hexadecimal).

4. Edit the string as required. The Digital Edit Position field displays the current 
cursor position as you type. The signature must be stated in either decimal (0-9) 
or hexadecimal (A-F) characters.

5. When you are through, click Write to save the UES data.

6. A message box asks you if you want to over write the JEDEC file? Click Yes.

7. Another message box tells you that the UES write to file was successful. Click 
OK. If you were to open the .JED file in a text editor, you would see the new 
UES data added to the bottom of the file, as shown in the following example:

.

Figure 2-15.  USERCODE/UES Editor

Table 2-12 describes the features of the USERCODE/UES Editor.

✍  NOTE The USERCODE/UES length of the device determines the 
actual number. In Step 3, the number 20 was used as an 
example.

Table 2-12.  USERCODE/UES Editor Features

Feature Description

USERCODE/UES 
Field...

Lets you specify a USERCODE/UES value to override the current value in the 
JEDEC file.

N User Electronic Signature Data*
U0000000000000000000000000000000000000000
0000000000000000000000010011110011001100
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Specifying the Number of Times a Chain is Processed

You can use the Repetitive Download dialog to specify a number of times that the 
ispVM System software will download the design chain. Use this feature as a test to 
make sure all of your cable connections are properly made.

To specify the number of times a chain is processed:

1. Choose ispTools ⇒  Repetitive Download to open the Repetitive Download 
dialog (Figure 2-16).

2. In the Number of repetitions field, select a number between 1-10.

3. In the Stop on number of Errors field, select a number between 1-10.

4. Click OK.

Figure 2-16.  Repetitive Download Dialog

Device Lists the possible devices that can be matched with the JEDEC file. You must 
choose a device from this list and then click Read to get the correct Max 
Bits/Digits information.

Digit Edit Position Shows the position of the cursor in the UES display field.

Read Reads the USERCODE/UES field in the JEDEC file and displays it in the 
UES display field.

Write Writes the value in the UES display field to the JEDEC file.

Browse Lets you browse for the JEDEC file.

Close Closes the USERCODE/UES Editor.

Table 2-12.  USERCODE/UES Editor Features (Continued)

Feature Description
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Table 2-13 describes the features of the Repetitive Download Dialog.

Running Board Diagnostics

You can use the Board Diagnostic command to check that the chain description 
matches the devices on the board.

To run board diagnostics:

1. Choose ispTools ⇒  Board Diagnostics to run the check and open the Board 
Diagnostics report.

2. Review the report and compare the Expected Devices column (left) to the 
Detected Devices column. If they do not match, you can edit the chain 
configuration file and run the diagnostic again until they match.

Setting ispVM System Software Options
You can change various options in the ispVM System software, including

■ Change port assignment

■ Change project directories

■ Specify Chain File Headings

■ Specify Autoscan options

■ Specify USERCODE/UES Display Options

Changing the Port Assignment

When you first launch the ispVM System software with the cables properly 
connected, it connects to the first available port that it detects. You can change the 
connecting port, as well as other cable options, using the Cable and Port Setting 
dialog.

Table 2-13.  Generate Repetitive Download File Dialog Features

Feature Description

Number of 
Repetitions

Lets you specify the number of times a chain is processed when you choose 
Project ⇒  Download.

Stop on Number of 
Errors

Lets you specify the number of errors (1-10) that can occur before stopping 
the download process.
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To change the port setup:

1. Choose Options ⇒  Cable and I/O Port Setup to open the Cable and I/O Port 
Setup dialog (Figure 2-17).

2. Choose the options that you want, and then click OK. If the cable is not 
connected or cannot be detected (if the board power in not on, for example), the 
ispVM System software displays an error message.

Figure 2-17.  Cable and I/O Port Setup Dialog

Table 2-14 describes the features of the Cable and I/O Port Setup Dialog.

Table 2-14.  Cable and Port I/O Setup Dialog Features

Feature Description

Port Setting Lets you specify the preferred parallel port address (0x0378,0x03BC or 
0x0278) for the software to use for download.

Auto-Detect Automatically detects the parallel port to which the download cable is 
connected. This feature works only with a Lattice ispDOWNLOAD cable, not 
a Vantis cable.

Cable Type Lets you select the download cable type, either Lattice ispDOWNLOAD cable 
or Vantis cable.

Key Attached to 
Parallel Port

Select this option if a parallel port security key is attached to the parallel port, 
so that the ispVM System software will generate signals to communicate with 
the chain through the key. Otherwise, remove the security key.

TRST/Reset pin 
connected

If you connect the TRST pin to the download cable, you must select this 
option. You must also specify whether the pin is active high or active low.

isEN/BSCAN pin 
connected

If you connect the isEN/BSCAN pin to the download cable, you must select 
this option. You must also specify whether the pin is active high or active low.
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Changing the Project Directories

You can change the default location of the ispVM System software directories using 
the File Location dialog. These directories are: Device Database location, Start 
directory, Working directory, and Log File name.

To change the project directory locations:

1. Choose Options ⇒  File Locations to open the Files Location dialog 
(Figure 2-18).

2. Edit the file locations that you want and click OK.

Figure 2-18.  Files Location Dialog

Table 2-15 describes the features of the Files Location Dialog.

Table 2-15.  Files Location Dialog Features

Feature Description

Device Database 
Location

Browse for the location of the Database directory. This directory holds the 
files describing supported devices.

Start Directory Browse for the location of the starting directory.

Working Directory Browse for the location of the working directory.

Log File Name Browse for the location of the log file.

Clear log file... If selected, the software automatically clears the contents of the log file every 
time you start the ispVM System software.
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Specifying Chain File Column Headings

There are eight column headings in the chain configuration file (.xcf) available for 
you to choose. The defaults are: Index, Device List, FileName/IR-Length, and 
Operation. You can change these headings using the Arrange Column dialog.

To specify chain file column headings:

1. Choose Options ⇒  Arrange Column to open the Arrange Column dialog 
(Figure 2-19).

2. Choose the options that you want and click Save.

Figure 2-19.  Arrange Column dialog

Table 2-16 describes the features of the Arrange Column Dialog.

Table 2-16.  Arrange Column Dialog Features

Feature Description

Operations 
Available

List of operations available as column headers for the Chain Configuration 
window. Use the Right arrow to add an operation to the Operations Displayed 
list.

Operations 
Displayed

List of operations currently in use as column headers for the Chain 
Configuration window. Use the Up and Down arrows to move a current 
header. Use the Left arrow to remove an operation from the list.

Right Arrow Moves the selected available operation to the Operations Displayed list.

Left Arrow Removes the selected operation from the Operations Displayed list.

Up Arrow Moves the selected operation up one position in the Operations Displayed list.
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Specifying AutoScan Options

When the ispVM System software scans the board, you can specify scanning options.

To specify AutoScan options:

■ Choose Options ⇒  Limited Scan if you want the ispVM System software to 
scan the board against all possible devices listed in the Select Device dialog 
(Figure 2-20), except for all ispLSI 3000 and 6000 devices.

■ Choose Options ⇒  Full Scan if you want the ispVM System software to scan 
the board against all possible devices listed in the Select Device dialog.

Figure 2-20.  Select Device Dialog

Down Arrow Moves the selected operation down one position in the Operations Displayed 
list.

Table 2-16.  Arrange Column Dialog Features (Continued)

Feature Description
ispVM System User Manual 2-35



The ispVM System Software
Table 2-17 describes the features of the Select Device Dialog.

Specifying USERCODE/UES Display Options

When you use the USERCODE/UES Editor, the UES field information in the .JED 
file can be displayed in either hexadecimal or decimal format. Use the Display 
USERCODE/UES Options command to toggle this setting.

To specify USERCODE/UES display options:

1. Choose Options ⇒  Display USERCODE/UES Options ⇒  Hexadecimal to 
display the UES field in hexadecimal format.

2. Choose Options ⇒  Display USERCODE/UES Options ⇒  Decimal to display 
the UES field in decimal format.

Table 2-17.  Select Device Dialog Features

Feature Description

Device Family Lets you specify the device family.

Generic JTAG – Non-Lattice device

• ispLSI

• ispGDS

• ispGDX

• ispGAL

• MACH

Device Lets you specify the device in the selected Device Family.

Package Lets you specify the package for the selected Device.

Device Description Shows the device PON (part order number) for the selected device and 
package.

Device 
Information

Contains device programming information.
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Installing/Unistalling the isp Windows NT Parallel 
Port Driver

You must install the isp Windows NT Parallel Port driver on Windows NT computers 
using the ispWinNT Driver dialog (Figure 2-21).  You can also use the isp WinNT 
dialog to uninstall the isp Window NT Parallel Port driver.

You must have administrator privileges to install or uninstall the isp Windows NT 
Parallel Port driver.

Installing the isp Windows NT Parallel Port Driver

To install the isp Windows NT Parallel Port driver:

■ 1.Choose ispTools > Install/Unistall LSC NT Driver to open the isp WinNT 
Driver dialog.

■ 2.Click Install, and follow the prompts, to install the isp WinNT driver.

Uninstalling the isp Windows NT Parallel Port Driver

To uninstall the isp Windows NT Parallel Port driver:

1. Choose ispTools > Install/Unistall LSC NT Driver to open the ispWinNT Driver 
dialog.

2. Click Uninstall, and follow the prompts, to uninstall the isp WinNT driver.

Figure 2-21.  isp WinNT Driver
ispVM System User Manual 2-37



The ispVM System Software
Table 2-17 describes the features of the isp WinNT Driver.

Table 2-18.  isp WinNT Driver features

Feature Description

Install Installs the isp WinNT Driver.

Uninstall Uninstalls the isp WinNT Driver.
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Chapter 3 The SVF Debugger

SVF Debugger is software, separate from ispVM System software, that helps you 
debug a Serial Vector Format (SVF) file. SVF Debugger allows you to program a 
device, and then edit, check syntax, debug and trace the process of an SVF file.

Included in this chapter are sections that describe:

■ SVF Files

■ Starting the SVF Debugger

■ Opening an Existing SVF File

■ Creating a New SFV File

■ Setting Device Programming Options

■ Setting Port Assignments and Options

■ Viewing SVF Processing

■ Setting and Removing Breakpoints in an SVF File

■ Processing an SVF File

■ Viewing the Log File

■ Editing an SVF File

■ Setting Windows Options
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About SVF Files
The SVF file is the media for exchanging descriptions of high-level 1149.1 bus 
operations. The SVF file is defined as an ASCII file, which consists of a set of SVF 
statements. In general, the 1149.1 bus operations consist of scan operations and 
movements between deferent stable states. Refer to the Serial Vector Format 
Specification Rev E for detailed definitions of SVF statement formats. Current SVF 
specifications are available from the Asset-Intertech website at 
www.asset-intertech.com. A sample SVF File is shown in Figure 3-1.

Figure 3-1.  SVF File Example

!Begin Test Program
TRST OFF; !Disable Test Reset line
ENDIR IDLE; !End IR scans in IDLE
ENDDR IDLE; !End DR scans in IDLE
HIR 8 TDI (00); !8 bits IR header
HDR 16 TDI (FFFF) 

! 16 bit DR header

TIR 16 TDI (0000); !16 bit IR trailer
TDR 8 TDI (12); !8 bit DR trailer
SIR 8 TDI (41); !8 bit IR scan
SDR 32 TDI (ABCD1234) 
TDO (11112222); !32 bit DR scan

STATE DRPAUSE; !Go to stable state
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SVF Debugger Software Support of SVF Operations

The SVF Debugger supports a selective set of SVF operations. Table 3-1 lists SVF 
operations supported by the SVF Debugger.

Table 3-1.  SVF Operations Supported by SVF Debugger

SVF Operation Description Support Status

ENDDR Specifies default end state for DR scan 
operations.

Full Support

ENDIR Specifies default end state for IR scan 
operations.

Full Support

HDR (Header Data Register) Specifies a 
header pattern which is placed at the 
beginning of subsequent DR scan 
operations.

Supports TDI keyword only. 
SMASK, TDO and MASK are not 
supported.

HIR (Header Instruction Register) Specifies 
a header pattern which is placed at the 
beginning of subsequent IR scan 
operations.

Supports TDI keyword only. 
SMASK, TDO and MASK are not 
supported.

RUNTEST Forces the 1149.1 bus to the 
RUN_TEST/IDLE state for a specified 
number of clocks.

Full Support

SDR (Scan data Register) Performs an 
1149.1 Data Register scan.

Supports TDI, TDO and MASK 
keywords. SMASK is ignored.

SIR (Scan Instruction Register) Performs an 
1149.1 Instruction Register scan.

Supports TDI, TDO and MASK 
keywords. SMASK is ignored.

STATE Forces the 1149.1 bus to a specified 
stable state.

Supports only single target state. The 
debugger does not allow the user to 
specify custom traverse path.

TDR (Trailer Data Register) Specified a 
trailer pattern which is appended to the 
end of subsequent DR scan operations.

Supports TDI keyword only. 
SMASK, TDO and MASK are not 
supported.

TIR (Trailer Data Register) Specified a 
trailer pattern which is appended to the 
end of subsequent IR scan operations

Supports TDI keyword only. 
SMASK, TDO and MASK are not 
supported.
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Starting the SVF Debugger
You can start SVF Debugger from within ispVM System software, or you can start 
SVF Debugger separately from the ispVM System software.

To start the SVF Debugger from within ispVM System software:

1. In the ispVM System software, choose ispTools ⇒  SVF Interpreter to open the 
SVF Interpreter dialog (Figure 3-2).

Figure 3-2.  SVF Interpreter Dialog

2. Click Debug. The SFV Debugger Software main window appears (Figure 3-3).

To start the SVF Debugger separately from the ispVM software:

■ Using Windows Explorer (Windows 95/98) or Windows NT Explorer (Windows 
NT), go to the directory containing your SVF Debugger software, and double-
click on the SVFdebugger.exe file.

or

■ From a DOS prompt or Run box, type: 
<drive>:\<ispVM directory>\svfdebugger.exe. 

The SFV Debugger main window appears (Figure 3-3).
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Figure 3-3.  SVF Debugger Main Window

Opening an Existing SVF File
You can open an existing SVF file for processing. The SVF Debugger Edit Window 
allows you to perform various editing functions on your SFV File. You can check, 
line by line, the SFV file for errors when you program your device.

To open an existing SVF file:

1. Choose File ⇒  Open to open the Open .SVF File dialog.

2. Use the Open .SVF File dialog to locate and select the desired SVF file, and then 
click Open. The SVF file opens in the SVF Debugger Edit Window (Figure 3-4). 
Some lines are long enough to be truncated in Figure 3-4. Such lines can be 
viewed in their entirety with the Edit Line dialog box.
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Figure 3-4.  SVF Debugger Edit Window.

Creating a New SFV File
You can create a new SVF file in the SVF Debugger.

To create a new empty SVF file:

■ Choose File ⇒  New to open the SVF Debugger Edit Window and create a new 
empty SVF file. The empty SVF file opens in the SVF Debugger Edit window 
(Figure 3-5). The SVF Options dialog (Figure 3-6) also opens.

✍  NOTE For more information about the SVF Debugger software 
Graphical User Interface (GUI), refer to Appendix B, “Using 
the SVF Debugger GUI”.
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Figure 3-5.  Empty SVF File Open in SVF Debugger Edit Window

Setting Device Programming Options
The SVF Options Dialog allows you to set options related to device programming. 
The SVF Options Dialog opens when you open an existing SVF File or you create a 
new empty SVF file. You can also open the SVF Options dialog using the 
Configuration ⇒  SVF Options command.

To open the SVF Options Dialog:

■ Choose Configuration ⇒  SVF Options to open the SVF Options dialog 
(Figure 3-6).
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Figure 3-6.  SVF Options Dialog

Table 3-2.  SVF Option Dialog Features

Feature Description

Ignore IR and DR 
Header/Trailer in 
SVF file

Ignores the HIR TIR HDR and TDR information in SVF file. If users set up 
the HIR TIR HDR TDR in SVF Option Dialog, the item must be selected.

Continue on Error Continue process SVF file even if there is an error and print all the 
information into the log file 

Mixed Chain Tells the SVF processor that the hardware configuration is a mixed chain, 
therefore disabling the ISP chain.

Instruction 
Register Header

Sets the HIR in number of bits (0-100)

Instruction 
Register Trailer

Sets the TIR in number of bits (0-100)

Data Register 
Header

Sets the HDR in number of bits (0-100)

Data Register 
Trailer

Sets the TDR in number of bits (0-100)

TCK frequency Sets the TCK clock frequency (1-30 Mhz). This value effects the speed of 
SVF processor.
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Setting Port Assignments and Options
You use the Cable and I/O Port Setup dialog to specify the preferred parallel port for 
download, select the port address, and select the download cable type.

To open the Cable and I/O Port Setting Dialog:

■ Choose Configuration ⇒  Cable and I/O Port Setup... to open the Cable and 
I/O Port Setup dialog (Figure 3-7).

Figure 3-7.  Cable and I/O Port Setup dialog

Table 3-3.  Cable and I/O Port Setup Dialog Features

Feature Description

Port Setting Lets you specify the preferred parallel port address (0x0378,0x03BC or 
0x0278) for the software to use for download.

Auto-Detect Automatically detects the parallel port to which the download cable is 
connected. This feature works only with a Lattice ispDOWNLOAD cable, not 
a Vantis cable.

Cable Type Selects download cable type (Lattice or Vantis)

Key Attached to 
Parallel Port

Select this option if a parallel port security key is attached to the parallel port, 
so that the ispVM System software will generate signals to communicate with 
the chain through the key. Otherwise, remove the security key.
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Viewing SVF Processing
You can view the progress of the SVF processing output with the Output dialog. If 
you wish to view the progress of the SVF processing, you must open the dialog before 
you begin processing the SVF File.

To open the Output Dialog:

Choose Configuration ⇒  SVF Output to open the Output dialog (Figure 3-8).

Figure 3-8.  Output Dialog
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Setting and Removing Breakpoints in an 
SVF File

You can set a breakpoint in your SVF file before processing the SVF file. The process 
will stop at the line you specify. When the process reaches the line you specify as a 
breakpoint, the process will stop. A dialog appears telling you that the breakpoint has 
been reached. After you click OK in the dialog, you can resume the process.

To set a breakpoint in an SVF File:

1. Select a line in your SVF file.

2. Choose Command ⇒  Breakpoint ⇒  Set Breakpoint.

To select next breakpoint:

1. Select a line in your SVF file.

2. Choose Command ⇒  Breakpoint ⇒  Next Breakpoint.

To select previous breakpoint:

1. Select a line in your SVF file.

2. Choose Command ⇒  Breakpoint ⇒  Previous Breakpoint.

To clear all breakpoints

1. Select the breakpoint you wish to remove in your SVF file.

2. Choose Command ⇒ Breakpoint ⇒  Clear All Breakpoints.

Table 3-4.  Output Dialog Features

Feature Description

Programming Pins Displays the value of the pins signal, either ‘1’ for HIGH or ‘0’ for LOW

Runtest clock 
pulses

Displays the number of delay clocks in RUNTEST statement

Data Register Displays the value of the TDO Signal, one bit at a time, when reading the data 
from the device. The results are compared with the expected value.

JTAG State Displays the State of TAP control state machine while processing a line in the 
SVF file.

Advanced Displays JTAG State Machine.
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Processing an SVF File
After you have set device programming options and port assignments, you can begin 
to process your SVF File with SVF Debugger. You can program a device with a 
download cable, and examine the output on the SVF Output dialog. You can step 
through a process, line by line, using the Step command. You can reset all variables 
and start a process from the beginning using the Reset command. You can view the 
process with the Output dialog. Refer to “Viewing SVF Processing” in this chapter 
for more information about viewing a process.

To process an SVF File:

■ Choose Command ⇒  Go.

To step through a process, line by line:

■ Choose Command ⇒  Step. The process will step through the SVF file line by 
line.

To reset a process and start a process from the beginning:

■ Choose Command ⇒  Reset.

Viewing the Log File
The SVF Debugger generates a log file if there are errors during the process, or if the 
Continue on Error option was selected in the SVF Options dialog. You can specify 
where to save the log file with the Log File Options dialog. You can clear the 
contents of the log file with the Clear Log File command.

To view a Log File:

■ Choose View ⇒  Log File. The log file will display in a text editor, as shown in 
Figure 3-9.
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Figure 3-9.  Sample Log File

You can save your Log File to a directory that you specify on your computer. 

To set Log File Options:

1. Choose Configuration ⇒  Log File Options to open the log file Options dialog 
(Figure 3-10). 

2. Specify the path to the directory that you wish to save your log file.   You can use 
the Browse button to navigate to the directory where you would like to save the 
log file.

3. If you wish to clear the contents of the log file every time that you start SVF 
Debugger software, check the Clear Log file each time start application box.

4. Click OK. 

Figure 3-10.  Log File Options dialog
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To clear the contents of the log file:

Choose Edit ⇒  Clear Log File.

Editing an SVF File
You can edit your SVF file using the commands in the Edit menu.

To edit an SVF file:

1. Select a line in your SVF file.

2. Make the edits using commands in the Edit menu, and click File ⇒  Save.

Setting Windows Options
You can use Cascade, Tile, and Arrange Icons commands to change the way the 
SVF Debugger software displays on your computer screen.

To arrange open windows in a cascade arrangement:

Choose Window ⇒  Cascade.

 To arrange open windows in a Tile arrangement:

Choose Window ⇒  Tile.

To arrange minimized open windows:

Choose Window ⇒ Arrange Icons. Minimized open windows in SVF Debugger will 
be arranged along the bottom of your computer screen.
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Appendix A Using the ispVM System GUI

This appendix describes the ispVM System software graphical user interface (GUI) in 
detail. Included in this appendix are sections that describe:

■ ispVM Tool Bar

■ ispVM Edit Bar

■ ispVM System Window Menus and Commands

■ ispVM System Software Chain Configuration Window

■ ispVM System Software Status Window

■ ispVM System Software Status Bar
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About the ispVM System Software User Interface
The ispVM System window (Figure A-1) consists of Menus, Tool Bar, Edit Bar, 
Chain Configuration window, and Status Window.

.

Figure A-1.  ispVM System Window.

✍  NOTE For more information about using the ispVM System 
software to create and edit device chains, refer to Chapter 2, 
“The ispVM System Software.”

Menus

Chain

Tool Bar

Status Window

Edit Bar

Status Bar

Configuration
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ispVM Toolbar
The ispVM System software toolbar (Figure A-2) contains icons that allow you to 
perform processing operations without the need to use menu commands.

Figure A-2.  ispVM System Software Toolbar

ispVM Edit Bar
The ispVM System software edit bar (Figure A-3) contains icons that allow you to 
perform editing operations without the need to use menu commands.

Figure A-3.  ispVM System Software Edit Bar
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ispVM System Window Menus and Commands
The following tables summarize the ispVM Main Window menu commands and 
associated tool bar icons, edit bar shortcut icons, and associated shortcuts.

File Menu
The File menu (Figure A-4) contains the New, Open, Import File, Print Setup, and 
Exit commands.

Figure A-4.  File Menu

Table A-1 lists and describes commands in the File menu, as well as associated 
toolbar icon and associated shortcut.

Table A-1.  File Menu commands and shortcuts

Command Icon Shortcut Description

New CTRL+N Creates an empty, untitled chain file.

Open... CTRL+O Opens the Open XCF File dialog, which lets you select 
an existing chain configuration file (.xcf). You can 
open multiple files at once. Use the Window menu 
commands to manage the multiple open files. Legacy 
chain files must be opened using File ⇒  Import.
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Import File N/A CTRL+I Opens the Open Import File dialog, which lets you 
select an ispDCD download configuration file (*.dld) 
or LatticePRO download configuration file (*.wch). 
You can use this method of starting a project instead of 
creating a new chain file.

Close N/A N/A Closes the active chain file. You should save changes 
to your files before you close them. If you attempt to 
close a file without saving, the software asks you if 
you want to save the current configuration setup.

Save CTRL+S Saves the active chain description to its current name 
and directory. When you save a chain description for 
the first time, the software displays the Save As dialog 
so you can name your chain file.

Save As... N/A N/A Opens the Save as XCF or DLD File dialog, which lets 
you name and save the active chain file.

Print... CTRL+P Opens the Print dialog, which lets you print the active 
chain file.

Print Preview N/A N/A Displays the active chain file as it would appear when 
printed. When you choose this command, the software 
replaces the main window with a print preview 
window that displays the chain file in its printed 
format. The print preview toolbar offers options to 
view either one or two pages at a time, move back and 
forth through the document, zoom in and out of pages, 
and initiate a print job.

Print Setup... N/A N/A Opens the Print Setup dialog, which lets you select a 
printer and a printer connection. 

Exit N/A N/A Closes the ispVM System application. You should 
save changes to your files before you exit. If you 
attempt to exit without saving, the software asks you if 
you want to save the current configuration setup.

Table A-1.  File Menu commands and shortcuts (Continued)

Command Icon Shortcut Description
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Edit Menu
The Edit menu (Figure A-5) contains the Cut, Copy, Paste, Add Chain Mark, 
Delete Chain Mark, Add Device, Delete Device, Edit Device, Move Device Up, 
Move Device Down, Reverse Chain Order, Set Chain Operations, Clear Status 
Window, and Clear Log File commands.

Figure A-5.  Edit Menu

Table A-2 lists and describes commands in the Edit menu, as well as associated tool 
bar icon, edit bar icon and associated shortcut.

Table A-2.  Edit Menu Commands

Command Icon Shortcut Description

Cut CTRL+X Removes the selected device from the active chain 
file and places it on the clipboard, erasing the 
previous contents of the clipboard. Then, you can 
paste the device from the clipboard into the chain 
file.

Copy CTRL+C Makes a copy of the selected device and places it on 
the clipboard, erasing the previous contents of the 
clipboard. Then, you can paste the device from the 
clipboard into the chain file.
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Paste CTRL+V Places the contents of the clipboard (a device) into 
the active chain file, one position below the 
currently selected device.

Add Chain 
Mark

CTRL+

Insert

Adds a chain mark into the active chain file, one 
position below the currently selected device. A 
chain mark separates a JTAG chain from an ISP 
chain.

Delete Chain 
Mark

CTRL+

Delete

Deletes the selected chain mark from the active 
chain file. Before you can delete the chain mark, 
you must first delete all its devices using the Delete 
Device command.

Add Device Insert Opens the Device Information dialog, which lets 
you insert a device into the active chain below the 
currently selected device and specify the 
configuration parameters for the device.

Delete Device Delete Deletes the currently selected device from the active 
chain file. There is no Undo for this command.

Edit Device Space Opens the Device Information dialog, which lets 
you change information about the device.

Move Device 
Up

N/A Moves the selected device up one position within its 
chain.

Move Device 
Down

N/A Moves the selected device down one position within 
its chain.

Reverse Chain 
Order

N/A Reverses the order of all the devices in the active 
chain file.

Table A-2.  Edit Menu Commands (Continued)

Command Icon Shortcut Description
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Set Chain 
Operations⇒  
Erase, 
Program, 
Verify

N/A N/A Sets the chain operation for the selected device to:

• Erase the current design pattern and the security 
fuse

• Download a new design pattern to the device. 
(Requires a JEDEC file to be specified).

• Verify the pattern with the original .jed file to 
ensure the device was programmed correctly.

Set Chain 
Operations⇒  
Erase, 
Program, 
Verify, Secure

N/A N/A Sets the chain operation for the selected device to:

• Erase the current design pattern and the security 
fuse

• Download a new design pattern to the device. 
(Requires a JEDEC file to be specified).

• Verify the pattern with the original .jed file to 
ensure the device was programmed correctly

• Set the security bit so that the device cannot be 
read.

Set Chain 
Operations ⇒  
Program Only

N/A N/A Sets the chain operation for the selected device to:

• Erase the current design pattern and the security 
fuse

• Download a new design pattern to the device. 
(Requires a JEDEC file to be specified).

Set Chain 
Operations ⇒  
Verify Only

N/A N/A Sets the chain operation for the selected device to:

• Verify the pattern with the original .jed file to 
ensure the device was programmed correctly. 
(Requires a JEDEC file to be specified).

Set Chain 
Operations ⇒  
Erase Only

N/A N/A Sets the chain operation for the selected device to:

• Erase the current design pattern and the security 
fuse

Set Chain 
Operations ⇒  
Bypass

N/A N/A Sets the chain operation for the selected device to:

• No operation will be performed on the device. 
The device is set to bypass mode.

Table A-2.  Edit Menu Commands (Continued)

Command Icon Shortcut Description
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View Menu
The View menu (Figure A-6) contains the Toolbar, Status Bar, Edit Bar, 
Background, and Font commands.

Figure A-6.  View Menu

Set Chain 
Operations ⇒  
Calculate 
Checksum

N/A N/A Sets the chain operation for the selected device to:

• All operation fields (ISP and JTAG) to the 
Checksum mode of operation. This function is 
activated when chain information is available.

Set Chain 
Operations ⇒  
Display ID

N/A N/A Sets the chain operation for the selected device to:

• Display the device ID.

Set Chain 
Operations⇒  
Display 
USERCODE

N/A N/A Sets the chain operation for the selected device to:

• Display the USERCODE in the JEDEC file.

Set Chain 
Operations ⇒  
Read and Save 
JEDEC

N/A N/A Sets the chain operation for the selected device to:

• Read the design pattern from the device and save 
it to a JEDEC file.

Set Chain 
Operations ⇒  
Secure Device

N/A N/A Sets the chain operation for the selected device to:

• Set the security bit so that the device cannot be 
read.

Clear Status 
Window

N/A N/A Clears the contents of the Message window, located 
directly above the Status Bar.

Clear Log File N/A N/A Clears the contents of the project log file.

Table A-2.  Edit Menu Commands (Continued)

Command Icon Shortcut Description
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Table A-3 lists and describes commands in the View menu,

Project Menu
The Project menu (Figure A-7) contains the Project Settings, Check 
Configuration, Download, Generate SVF File, Generate ATE File, and View Log 
File commands.

Figure A-7.  Project Menu

Table A-4 lists and describes commands in the Project menu, as well as associated 
toolbar icon.

Table A-3.  View Menu Commands

Command Description

Toolbar Toggles the display of the Toolbar.

Status Bar Toggles the display of the Status Bar.

Edit Bar Toggles the display of the Edit Bar.

Background... Opens the Background dialog, which lets you specify a background graphic and 
color for the Main Window, as well as other display attributes.

Font... Opens the Font dialog, which lets you specify the font, font style, and size of the 
font for text appearing in the Chain Configuration window.

Table A-4.  Project Menu Commands

Command Icon Description

Project 
Settings

N/A Opens the Project Settings dialog, which lets you specify how the 
ispVM System software will process the active chain configuration.
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ispTools Menu
The ispTools menu (Figure A-8) contains the SVF Interpreter, Scan Chain, Scan 
Mixed Chain, USERCODE/UES Editor, Repetitive Download, and Board 
Diagnostics commands.

Figure A-8.  ispTools Menu

Check 
Configuration 
Setup

Verifies that each device has a .jed file attached and checks the 
operation selection for each device. Prints the configuration status 
(pass/fail) for each device in the configuration. A successful 
message appears in the Messages window.

Download Downloads the design files to the daisy-chained devices, as 
specified.

Generate SVF 
File...

Opens the Generate SVF File dialog, which lets you build an SVF 
file for a single-device or Sequential Chain.

Generate ATE 
File...

Opens the Generate ATE File dialog, which lets you build a test file 
formatted for Genrad, HP, and Teradyne testers, as well as a 
Generic Vector format.

View Log File Opens the project log file, which is an ASCII text report file 
summarizing the results of the ispVM System software operations.

Generate ISC 
File

Opens the JEDEC to ISC Data File converter dialog which allows 
you to convert JEDEC files to ISC files.

Table A-4.  Project Menu Commands (Continued)

Command Icon Description
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Table A-5 lists and describes commands in the ispTools menu, as well as associated 
toolbar and edit bar icon shortcuts.

Table A-5.  ispTools Menu Commands

Command Icon Description

SVF 
Interpreter...

N/A Opens the SVF Interpreter dialog, which lets you specify the single 
device SVF file for processing by the SVF Interpreter when you 
click Run. You can also open the SVF Debugger when you click 
Debug.

Scan Chain Automatically scans and detects the devices on the chain.

Scan Mixed 
Chain

Automatically scans and detects the devices on the mixed chain.

USERCODE/
UES Editor...

N/A Opens the Open .JED File dialog, which lets you specify the 
JEDEC file to edit the USERCODE/UES field.

Repetitive 
Download...

N/A Opens the Repetitive Download dialog, which lets you specify the 
number of times a chain is processed, based on values specified in 
the dialog.

Board 
Diagnostics...

N/A Check that the chain description matches the devices on the board.

Convert 
Composite to 
JEDEC File

N/A Opens the Convert Composite to JEDEC Files dialog, which 
allows you to convert Composite files (*.CMP) to JEDEC files 
(*.JED).

Install/ 
Uninstall LSC 
NT Driver

N/A Opens the isp WinNT dialog, which allows you to install the NT 
Parallel Port Driver application.
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Options Menu
The Options menu (Figure A-9) contains the Cable and I/O Port Setup, File 
Locations, Arrange Column, AutoScan Options, and Display USERCODE/UES 
Options commands.

Figure A-9.  Options Menu

Table A-6 lists and describes commands in the Options menu.

Table A-6.  Options Menu Commands

Command Description

Cable and I/O 
Port Setup...

Opens the Cable and I/O Port Setup dialog, which lets you specify the preferred 
parallel port for the ispVM System software to use for download. When you start 
the program with the cables connected properly, the software detects the default 
port assignment.

File 
Locations...

Opens the File Locations dialog, which lets you specify the location of your 
project directories.

 Arrange 
Column...

Opens the Arrange Column dialog, which lets you rearrange, add, or remove the 
column headings for the Chain Configuration window.

AutoScan 
Options ⇒  
Limited Scan

The ispVM System software scans the board against all possible devices listed in 
the Select Device dialog, except for all ispLSI 3000 and 6000 devices.

The ispLSI 3K and 6K devices require the ispVM System software to shift in the 
IDCODE instruction in order to read back the device ID. Depending on the other 
JTAG devices on the board, you may not want to shift in the IDCODE instruction 
in case the IDCODE is intrusive to the other non-Lattice devices.

AutoScan 
Options ⇒  Full 
Scan

The ispVM System software scans the board against all the possible devices listed 
in the Select Device dialog.
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Window Menu
The Window menu (Figure A-10) contains the Cascade, Tile, and Arrange Icons 
commands.

Figure A-10.  Window Menu

Table A-7 lists and describes commands in the Window menu.

Display 
USERCODE
/UES
Options ⇒  
Hexadecimal

Sets the USERCODE/UES to display in hexadecimal format.

Display 
USERCODE
/UES
Options ⇒  
ASCII

Sets the USERCODE/UES to display in ASCII format.

Display 
USERCODE/
UES Options 
⇒  Decimal

Sets the USERCODE/UES to display in decimal format.

Table A-7.  Window Menu Commands

Command Description

Cascade Arranges multiple opened windows in an overlapped fashion.

Tile Arrange multiple opened windows in a non-overlapped fashion.

Arrange Icons Arranges the icons for minimized windows at the bottom of the main window. If 
there is an open configuration chain file window at the bottom of the main window, 
then some or all of the icons may not be visible because they will be underneath 
this chain file window. 

Table A-6.  Options Menu Commands (Continued)

Command Description
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Help Menu
The Help menu (Figure A-11) contains the Help Topics, Tutorials, Manual, and 
About ispVM System commands.

Figure A-11.  Help Menu

Table A-8 lists and describes commands in the Help menu, as well as associated 
toolbar and edit bar icon shortcuts.

ispVM System Software Chain Configuration Window

The Chain Configuration Window displays the chain configuration file, and allows 
you to edit and process the chain configuration file using the ispVM System software.

ispVM System Software Status Window

The Status Window displays the status of your chain configuration file process.

Table A-8.  Menu Commands

Command Toolbar Description

 Help Topics Opens the ispVM System Help to the opening screen. Using the 
Contents tab, you can navigate to ispVM System concepts and 
background information, step-by-step instructions for using the 
ispVM System software, and various types of reference 
information.

Tutorials N/A Opens the ispVM System Help Tutorials.

 Manual N/A Opens the ispVM System User Guide.

About ispVM 
System

N/A Opens the ispVM System dialog, which contains software and 
supported device list version numbers and system resource 
information.
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ispVM System Software Status Bar

The Status Bar is displayed at the bottom of the ispVM System software window. 

To hide or show the Status Bar:

■ Choose View > Status Bar.

The left area of the Status Bar describes actions of menu items as you use the arrow 
keys to navigate through menus. This area similarly shows messages that describe the 
actions of Toolbar and Edit Bar buttons as you move the mouse over the buttons.

The right areas of the Status Bar indicate which keyboard keys are latched down.
A-16 ispVM System User Manual



Appendix B Using the SVF Debugger GUI

This appendix describes the SVF Debugger graphical user interface (GUI) in detail. 
Included in this appendix are sections that describe:

■ SVF Debugger Toolbar

■ SVF Debugger Menus and Commands

■ SVF File Window

■ SVF Debugger Status Bar
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About the SVF Debugger User Interface
The SVF Debugger edit window (Figure B-1) consists of Menus, Tool Bar, SVF File, 
and Status Bar.

Figure B-1.  SVF Debugger Edit Window.

✍  NOTE For more information about using the SVF Debugger 
software to debug and edit SVF files, refer to Chapter 3, 
“The SVF Debugger.”

Menus

SVF File

Tool Bar

Status Bar
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About the SVF Debugger User Interface
SVF Debugger Toolbar
The SVF Debugger toolbar (Figure B-2) contains shortcut icons that allow you to 
perform processing operations without the need to use menu commands.

Figure B-2.  SVF Debugger Toolbar

SVF Debugger Menus and Commands
The following tables summarize the SVF Debugger menu commands, associated tool 
bar shortcut icons, and associated shortcuts.

File Menu
The File menu (Figure B-3) contains the New, Open, Close, Save, Save As, Print, 
Print Preview, Print Setup, and Exit commands.

Figure B-3.  File Menu

Print

Save

Open

New

GoCopy

PasteCut

Undo

Redo

Clear All
Break
Points

Insert
Break
Point

Step Reset

SVF View
Options

SVF
Output

Log
File

Previous
Break
Point

Next
Break
Point
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Table B-1 lists and describes commands in the File menu, as well as associated 
toolbar icon and associated shortcut.

Table B-1.  File Menu Commands

Command
Toolbar
Icon Shortcut Description

New CTRL + N Creates a new blank SVF file window.

Open... CTRL + O Opens the Open .SVF File dialog, which lets you 
select an existing chain file (.svf). You can open 
multiple files at once. Use the Window menu 
commands to manage the multiple open files.

Close N/A N/A Closes the SVF File. You should save changes to your 
files before you close. If you attempt to close without 
saving, the software asks you if you want to save the 
current configuration setup.

Save CTRL + S Saves the SVF File. If the SVF file has not been saved 
before, opens the Save as .SVF File dialog and allows 
you to save the current SVF File.

Save As... N/A N/A Opens the Save as .SVF File dialog and allows you to 
save the current SVF File with different file name.

Print... CTRL + P Prints the current SVF File.

Print Preview N/A N/A Displays a preview version of the SVF File on your 
computer screen before you print the SVF File.

Print Setup... N/A N/A Opens the Print Setup dialog, which lets you select a 
printer and a printer connection.

Exit N/A N/A Closes the SVF Debugger application. You should 
save changes to your files before you exit. If you 
attempt to exit without saving, the software asks you 
if you want to save the current configuration setup.
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Edit Menu
The Edit menu (Figure B-4) contains the Undo, Redo, Cut, Copy, Paste, Delete, 
Select All, Find, Find Next, Find Previous, Replace, Go to, Read Only, and Clear 
Log File commands.

Figure B-4.  Edit Menu

Table B-2 lists and describes commands in the Edit menu, as well as associated 
toolbar icon and associated 
shortcut.

Table B-2.  Edit Menu Commands

Command
Toolbar
Icon Shortcut Description

Undo CTRL+Z Cancels the previous action.

Redo CTRL+Z Cancels the previous cancellation of an action.

Cut CTRL+X Removes selected text from the SVF file and places it 
on the clipboard, erasing the previous contents of the 
clipboard. Then, you can paste the text elsewhere in 
the SVF file, or into another SVF file.

Copy CTRL+C Copies selected text.
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View Menu
The View menu (Figure B-5) contains the Toolbar, Status Bar, and Log File 
commands.

Figure B-5.  View Menu

Table B-3 lists and describes commands in the View menu, as well as associated 
toolbar icon.

Paste CTRL+V Pastes selected text.

Delete N/A Delete Deletes selected text.

Select All N/A CTRL+A Selects all the text of the SVF file.

Find N/A CTRL+F Finds a string in the SVF file.

Find Next N/A F3 Finds the next occurrence of a string in the SVF file.

Find Previous N/A SHIFT+F3 Finds the previous occurrence of a string in the SVF 
file.

Replace N/A CTRL+H Finds each occurrence of a string in the SVF and 
replaces it with another.

Go to N/A CTRL+G Goes to a specific line in the SVF file.

Read Only N/A N/A Makes the SVF file Read Only.

Clear Log File N/A N/A Clears the contents of a log file.

Table B-3.  View Menu Commands

Command
Toolbar
Icon Description

Tool Bar N/A Toggles the display of the Toolbar.

Table B-2.  Edit Menu Commands (Continued)

Command
Toolbar
Icon Shortcut Description
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Configuration Menu
The Configuration menu (Figure B-6) contains the Cable and I/O Port Setup, SVF 
Options, SVF Output, and Log File Options commands.

Figure B-6.  Configuration Menu

Table B-4 lists and describes commands in the Configuration menu, as well as 
associated toolbar icon.

Status Bar N/A Toggles the display of the Status Bar.

Log File View the result file. When problems happen when processing the 
SVF file or users choose “Continue on Download” option, all of the 
messages will be printed into the log file.

Table B-4.  Configuration Menu Commands

Command
Toolbar
Icon Description

Cable and I/O 
Port Setup

N/A Opens the Cable and I/O Port Setup dialog, which lets you specify 
the preferred parallel port for the ispVM System software to use for 
download. When you start the program with the cables connected 
properly, the software detects the default port assignment.

SVF Options Opens the SVF Options dialog.

SVF Output Opens the Output dialog.

Table B-3.  View Menu Commands (Continued)

Command
Toolbar
Icon Description
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Log File 
Options

N/A Opens the Log File Options dialog.

Table B-4.  Configuration Menu Commands (Continued)

Command
Toolbar
Icon Description
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Command Menu
The Command menu (Figure B-7) contains the Insert Breakpoint, Remove 
Breakpoint, Step, Go, and Reset commands.

Figure B-7.  Command Menu

Table B-5 lists and describes commands in the Command menu, as well as 
associated toolbar and associated shortcut.

Table B-5.  Command Menu Commands

Command
Toolbar
Icon Shortcut Description

Insert 
Breakpoint

N/A Insert a breakpoint while processing the SVF file. The 
process will stop at that line. Only one breakpoint can 
be used at a time.

N/A Jump to the next breakpoint.

N/A Jump to the previous breakpoint.

Clear All 
Breakpoints

N/A Clear all breakpoints.

Step F11 User can start from the beginning and process the 
SVF file step by step though each line. The result will 
display in Output dialog.
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Window Menu
The Window menu (Figure B-8) contains the Cascade, Tile, and Arrange Icons 
commands.

Figure B-8.  Window Menu

Table B-6 lists and describes commands in the Window menu, as well as associated 
toolbar icon.

Go F5 Process the SVF file.

Reset CTRL+F10 Reset all the variables and start from the beginning.

Table B-6.  Window Menu Commands

Command Description

Cascade Arranges multiple opened windows in an overlapped fashion.

Tile Arrange multiple opened windows in a non-overlapped fashion.

Arrange Icons Arranges the icons for minimized windows at the bottom of the main window. 

Table B-5.  Command Menu Commands (Continued)

Command
Toolbar
Icon Shortcut Description
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Help Menu
The Help menu (Figure B-9) contains the Help Topics and About SVF Debugger 
commands.

Figure B-9.  Help Menu

Table B-7 lists and describes commands in the Help menu, as well as associated 
toolbar icon shortcut.

SVF File Window

The SVF File Window displays the SVF file, and allows you to process, debug, and 
edit the SVF File using the SVF Debugger software.

SVF Debugger Status Bar

The Status Bar is displayed at the bottom of the SVF Debugger software  window. 

To hide or show the Status Bar:

■ Choose View > Status Bar.

The left area of the Status Bar describes actions of menu items as you use the arrow 
keys to navigate through menus. This area similarly shows messages that describe the 
actions of Toolbar and Edit Bar buttons as you move the mouse over the buttons.

The right areas of the Status Bar indicate which keyboard keys are latched down.

Table B-7.  SVF Edit Window Help Menu Commands

Command Description

Help Topics Opens the SVF Debugger Help to the opening screen. Using the Contents tab, you 
can navigate to SVF Debugger help topics.

About SVF 
Debugger

Opens the SVF Debugger dialog, which contains software version number.
ispVM System User Manual B-11



Using the SVF Debugger GUI
B-12 ispVM System User Manual



Appendix C ispVM Command Line Mode

This appendix describes how you can run ispVM System software from a 32-bit DOS 
command line. You can process chain description files (.xcf) or configuration setup 
files (.dld) using the command line mode.

Included in this appendix are sections that describe:

■ Running ispVM from Command Line

■ ispVM System Software Commands

■ ispVM System Software Command Line Syntax
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ispVM Command Line Mode
Running ispVM from Command Line
The ispVM System software command line syntax runs ispVM System software 
processes chain configuration files (.xcf) and configuration setup files (.dld). You can 
specify the following using ispVM System software command line syntax:

■ File to be processed (.xcf or .dld)

■ Process type (Turbo or Sequential)

■ Cable type (Lattice or Vantis)

■ One of the following port addresses: 

• 0x0378 (LPT1)

• 0x0278 (LPT2

• 0x03BC (LPT3)

■ Output mode (display output messages in output window or run in quiet mode)

ispVM System Software Commands
The following commands are used in ispVM System software command line mode:

File name
filename.xcf - Chain Configuration File (.xcf)

filename.dld - Configuration Setup File (.dld)

Process Type

/t - Process using Turbo mode

/s - Process using Sequential mode 

Default is process using Sequential mode

Cable Type

/Lattice - Lattice download cable

/Vantis - Vantis download cable

Default is Lattice download cable
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ispVM System Software Command-Line Syntax
Parallel Port Address

/0x0378 - LPT1 parallel port

/0x0278 - LPT2 parallel port

/0x03BC - LPT3 parallel port

Default is 0x0378 LPT1 parallel port

Output

/o - display output in output window

Default is quiet mode

ispVM System Software Command-Line Syntax
The ispvm System software command-line mode uses the following syntax:

<drive>:\<ispvm directory>\ispvm.exe filename.xcf 
/<process type> /<cable type> /<parallel port address> 
/<output mode>

Command Line Example

The following example shows a chain description file named demo.xcf, processed 
in Turbo mode, using a Lattice download cable, parallel port LPT1 selected, and 
displaying output in the output window:

c:\ispTools\ispvm\ispvm.exe demo.xcf /t /Lattice 
/0x0378 /o
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